summaryrefslogtreecommitdiff
path: root/python-gios.spec
diff options
context:
space:
mode:
authorCoprDistGit <copr-devel@lists.fedorahosted.org>2023-02-25 02:08:42 +0000
committerCoprDistGit <copr-devel@lists.fedorahosted.org>2023-02-25 02:08:42 +0000
commit1c59b2d4567448d7b5ffbbbaa42cd2bad7de046e (patch)
tree14dc7fc0629eb8e1d77bef684b62cffd879c9d8e /python-gios.spec
parente20bf7c512526f4180f7d2fc8a1fe01083866c77 (diff)
automatic import of python3-giosopeneuler20.03
Diffstat (limited to 'python-gios.spec')
-rw-r--r--python-gios.spec262
1 files changed, 262 insertions, 0 deletions
diff --git a/python-gios.spec b/python-gios.spec
new file mode 100644
index 0000000..8aacad9
--- /dev/null
+++ b/python-gios.spec
@@ -0,0 +1,262 @@
+%global _empty_manifest_terminate_build 0
+Name: python-gios
+Version: 3.1.0
+Release: 1
+Summary: Python wrapper for getting air quality data from GIOŚ servers.
+License: Apache-2.0 License
+URL: https://github.com/bieniu/gios
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/a7/16/e837d7697f40e42d77d92c68b4dcf38329529b355cd77837d0e5ebeb43fe/gios-3.1.0.tar.gz
+BuildArch: noarch
+
+Requires: python3-aiohttp
+Requires: python3-dacite
+
+%description
+[![GitHub Release][releases-shield]][releases]
+[![PyPI][pypi-releases-shield]][pypi-releases]
+[![PyPI - Downloads][pypi-downloads]][pypi-statistics]
+[![Buy me a coffee][buy-me-a-coffee-shield]][buy-me-a-coffee]
+[![PayPal_Me][paypal-me-shield]][paypal-me]
+
+# gios
+Python wrapper for getting air quality data from [GIOŚ (Główny Inspektorat Ochrony Środowiska)](http://www.gios.gov.pl/pl/stan-srodowiska/monitoring-jakosci-powietrza)
+
+## How to find station_id
+- go to http://powietrze.gios.gov.pl/pjp/current
+- find on the map a measurement station located closest to your home
+- go to "More infotmation" link
+- look at site address, for ex. for this address https://powietrze.gios.gov.pl/pjp/current/station_details/table/10124/3/0 `station_id` is 10124
+
+## How to use package
+```python
+"""Example for GIOS."""
+import asyncio
+import logging
+
+from aiohttp import ClientError, ClientSession
+
+from gios import ApiError, Gios, InvalidSensorsData, NoStationError
+
+GIOS_STATION_ID = 568
+
+logging.basicConfig(level=logging.DEBUG)
+
+
+async def main() -> None:
+ """Run main function."""
+ async with ClientSession() as websession:
+ gios = Gios(GIOS_STATION_ID, websession)
+ try:
+ data = await gios.async_update()
+ except (ApiError, NoStationError, InvalidSensorsData, ClientError) as error:
+ print(error)
+ return
+
+ latitude = gios.latitude
+ longitude = gios.longitude
+ station_name = gios.station_name
+ print(f"Longitude: {longitude}")
+ print(f"Latitude: {latitude}")
+ print(f"Station name: {station_name}")
+ print(data)
+
+
+loop = asyncio.get_event_loop()
+loop.run_until_complete(main())
+loop.close()
+```
+[releases]: https://github.com/bieniu/gios/releases
+[releases-shield]: https://img.shields.io/github/release/bieniu/gios.svg?style=popout
+[pypi-releases]: https://pypi.org/project/gios/
+[pypi-statistics]: https://pepy.tech/project/gios
+[pypi-releases-shield]: https://img.shields.io/pypi/v/gios
+[pypi-downloads]: https://pepy.tech/badge/gios/month
+[buy-me-a-coffee-shield]: https://img.shields.io/static/v1.svg?label=%20&message=Buy%20me%20a%20coffee&color=6f4e37&logo=buy%20me%20a%20coffee&logoColor=white
+[buy-me-a-coffee]: https://www.buymeacoffee.com/QnLdxeaqO
+[paypal-me-shield]: https://img.shields.io/static/v1.svg?label=%20&message=PayPal.Me&logo=paypal
+[paypal-me]: https://www.paypal.me/bieniu79
+
+
+%package -n python3-gios
+Summary: Python wrapper for getting air quality data from GIOŚ servers.
+Provides: python-gios
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+%description -n python3-gios
+[![GitHub Release][releases-shield]][releases]
+[![PyPI][pypi-releases-shield]][pypi-releases]
+[![PyPI - Downloads][pypi-downloads]][pypi-statistics]
+[![Buy me a coffee][buy-me-a-coffee-shield]][buy-me-a-coffee]
+[![PayPal_Me][paypal-me-shield]][paypal-me]
+
+# gios
+Python wrapper for getting air quality data from [GIOŚ (Główny Inspektorat Ochrony Środowiska)](http://www.gios.gov.pl/pl/stan-srodowiska/monitoring-jakosci-powietrza)
+
+## How to find station_id
+- go to http://powietrze.gios.gov.pl/pjp/current
+- find on the map a measurement station located closest to your home
+- go to "More infotmation" link
+- look at site address, for ex. for this address https://powietrze.gios.gov.pl/pjp/current/station_details/table/10124/3/0 `station_id` is 10124
+
+## How to use package
+```python
+"""Example for GIOS."""
+import asyncio
+import logging
+
+from aiohttp import ClientError, ClientSession
+
+from gios import ApiError, Gios, InvalidSensorsData, NoStationError
+
+GIOS_STATION_ID = 568
+
+logging.basicConfig(level=logging.DEBUG)
+
+
+async def main() -> None:
+ """Run main function."""
+ async with ClientSession() as websession:
+ gios = Gios(GIOS_STATION_ID, websession)
+ try:
+ data = await gios.async_update()
+ except (ApiError, NoStationError, InvalidSensorsData, ClientError) as error:
+ print(error)
+ return
+
+ latitude = gios.latitude
+ longitude = gios.longitude
+ station_name = gios.station_name
+ print(f"Longitude: {longitude}")
+ print(f"Latitude: {latitude}")
+ print(f"Station name: {station_name}")
+ print(data)
+
+
+loop = asyncio.get_event_loop()
+loop.run_until_complete(main())
+loop.close()
+```
+[releases]: https://github.com/bieniu/gios/releases
+[releases-shield]: https://img.shields.io/github/release/bieniu/gios.svg?style=popout
+[pypi-releases]: https://pypi.org/project/gios/
+[pypi-statistics]: https://pepy.tech/project/gios
+[pypi-releases-shield]: https://img.shields.io/pypi/v/gios
+[pypi-downloads]: https://pepy.tech/badge/gios/month
+[buy-me-a-coffee-shield]: https://img.shields.io/static/v1.svg?label=%20&message=Buy%20me%20a%20coffee&color=6f4e37&logo=buy%20me%20a%20coffee&logoColor=white
+[buy-me-a-coffee]: https://www.buymeacoffee.com/QnLdxeaqO
+[paypal-me-shield]: https://img.shields.io/static/v1.svg?label=%20&message=PayPal.Me&logo=paypal
+[paypal-me]: https://www.paypal.me/bieniu79
+
+
+%package help
+Summary: Development documents and examples for gios
+Provides: python3-gios-doc
+%description help
+[![GitHub Release][releases-shield]][releases]
+[![PyPI][pypi-releases-shield]][pypi-releases]
+[![PyPI - Downloads][pypi-downloads]][pypi-statistics]
+[![Buy me a coffee][buy-me-a-coffee-shield]][buy-me-a-coffee]
+[![PayPal_Me][paypal-me-shield]][paypal-me]
+
+# gios
+Python wrapper for getting air quality data from [GIOŚ (Główny Inspektorat Ochrony Środowiska)](http://www.gios.gov.pl/pl/stan-srodowiska/monitoring-jakosci-powietrza)
+
+## How to find station_id
+- go to http://powietrze.gios.gov.pl/pjp/current
+- find on the map a measurement station located closest to your home
+- go to "More infotmation" link
+- look at site address, for ex. for this address https://powietrze.gios.gov.pl/pjp/current/station_details/table/10124/3/0 `station_id` is 10124
+
+## How to use package
+```python
+"""Example for GIOS."""
+import asyncio
+import logging
+
+from aiohttp import ClientError, ClientSession
+
+from gios import ApiError, Gios, InvalidSensorsData, NoStationError
+
+GIOS_STATION_ID = 568
+
+logging.basicConfig(level=logging.DEBUG)
+
+
+async def main() -> None:
+ """Run main function."""
+ async with ClientSession() as websession:
+ gios = Gios(GIOS_STATION_ID, websession)
+ try:
+ data = await gios.async_update()
+ except (ApiError, NoStationError, InvalidSensorsData, ClientError) as error:
+ print(error)
+ return
+
+ latitude = gios.latitude
+ longitude = gios.longitude
+ station_name = gios.station_name
+ print(f"Longitude: {longitude}")
+ print(f"Latitude: {latitude}")
+ print(f"Station name: {station_name}")
+ print(data)
+
+
+loop = asyncio.get_event_loop()
+loop.run_until_complete(main())
+loop.close()
+```
+[releases]: https://github.com/bieniu/gios/releases
+[releases-shield]: https://img.shields.io/github/release/bieniu/gios.svg?style=popout
+[pypi-releases]: https://pypi.org/project/gios/
+[pypi-statistics]: https://pepy.tech/project/gios
+[pypi-releases-shield]: https://img.shields.io/pypi/v/gios
+[pypi-downloads]: https://pepy.tech/badge/gios/month
+[buy-me-a-coffee-shield]: https://img.shields.io/static/v1.svg?label=%20&message=Buy%20me%20a%20coffee&color=6f4e37&logo=buy%20me%20a%20coffee&logoColor=white
+[buy-me-a-coffee]: https://www.buymeacoffee.com/QnLdxeaqO
+[paypal-me-shield]: https://img.shields.io/static/v1.svg?label=%20&message=PayPal.Me&logo=paypal
+[paypal-me]: https://www.paypal.me/bieniu79
+
+
+%prep
+%autosetup -n gios-3.1.0
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-gios -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Sat Feb 25 2023 Python_Bot <Python_Bot@openeuler.org> - 3.1.0-1
+- Package Spec generated