summaryrefslogtreecommitdiff
path: root/python-hatasmota.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-hatasmota.spec')
-rw-r--r--python-hatasmota.spec76
1 files changed, 76 insertions, 0 deletions
diff --git a/python-hatasmota.spec b/python-hatasmota.spec
new file mode 100644
index 0000000..ad81260
--- /dev/null
+++ b/python-hatasmota.spec
@@ -0,0 +1,76 @@
+%global _empty_manifest_terminate_build 0
+Name: python-HATasmota
+Version: 0.6.4
+Release: 1
+Summary: Python module to help parse and construct Tasmota MQTT messages.
+License: MIT
+URL: https://github.com/emontnemery/hatasmota
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/ce/3f/6c46a3e08bd062b54670d9436be0f4e63e17ada236a7e239d47e72d59f64/HATasmota-0.6.4.tar.gz
+BuildArch: noarch
+
+Requires: python3-attrs
+Requires: python3-voluptuous
+
+%description
+# hatasmota
+
+
+%package -n python3-HATasmota
+Summary: Python module to help parse and construct Tasmota MQTT messages.
+Provides: python-HATasmota
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+%description -n python3-HATasmota
+# hatasmota
+
+
+%package help
+Summary: Development documents and examples for HATasmota
+Provides: python3-HATasmota-doc
+%description help
+# hatasmota
+
+
+%prep
+%autosetup -n HATasmota-0.6.4
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-HATasmota -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Sat Feb 25 2023 Python_Bot <Python_Bot@openeuler.org> - 0.6.4-1
+- Package Spec generated