summaryrefslogtreecommitdiff
path: root/python-hstspreload.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-hstspreload.spec')
-rw-r--r--python-hstspreload.spec161
1 files changed, 161 insertions, 0 deletions
diff --git a/python-hstspreload.spec b/python-hstspreload.spec
new file mode 100644
index 0000000..53e5b1b
--- /dev/null
+++ b/python-hstspreload.spec
@@ -0,0 +1,161 @@
+%global _empty_manifest_terminate_build 0
+Name: python-hstspreload
+Version: 2023.1.1
+Release: 1
+Summary: Chromium HSTS Preload list as a Python package
+License: BSD-3
+URL: https://github.com/sethmlarson/hstspreload
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/bc/6b/dc96f2d6e9ab7f0ce56e647d24728ee92219803b023705c98748483270b6/hstspreload-2023.1.1.tar.gz
+BuildArch: noarch
+
+
+%description
+# hstspreload
+
+
+[![Version](https://img.shields.io/pypi/v/hstspreload)](https://pypi.org/project/hstspreload)
+[![Downloads](https://pepy.tech/badge/hstspreload)](https://pepy.tech/project/hstspreload)
+![CI](https://img.shields.io/github/workflow/status/sethmlarson/hstspreload/CI/master)
+
+Chromium HSTS Preload list as a Python package.
+
+Install via `python -m pip install hstspreload`
+
+See https://hstspreload.org for more information regarding the list itself.
+
+## API
+
+The package provides a single function: `in_hsts_preload()` which takes an
+IDNA-encoded host and returns either `True` or `False` regarding whether
+that host should be only accessed via HTTPS.
+
+## Changelog
+
+This package is built entirely by an automated script running once a month.
+If you need a release sooner of the package please reach out and I'll trigger a release manually.
+
+This script gathers the HSTS Preload list by monitoring
+[this file in the Chromium repository](https://chromium.googlesource.com/chromium/src/+/main/net/http/transport_security_state_static.json). Changes to the HSTS Preload list can be seen in the history of that file.
+
+## License
+
+BSD-3
+
+
+%package -n python3-hstspreload
+Summary: Chromium HSTS Preload list as a Python package
+Provides: python-hstspreload
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+%description -n python3-hstspreload
+# hstspreload
+
+
+[![Version](https://img.shields.io/pypi/v/hstspreload)](https://pypi.org/project/hstspreload)
+[![Downloads](https://pepy.tech/badge/hstspreload)](https://pepy.tech/project/hstspreload)
+![CI](https://img.shields.io/github/workflow/status/sethmlarson/hstspreload/CI/master)
+
+Chromium HSTS Preload list as a Python package.
+
+Install via `python -m pip install hstspreload`
+
+See https://hstspreload.org for more information regarding the list itself.
+
+## API
+
+The package provides a single function: `in_hsts_preload()` which takes an
+IDNA-encoded host and returns either `True` or `False` regarding whether
+that host should be only accessed via HTTPS.
+
+## Changelog
+
+This package is built entirely by an automated script running once a month.
+If you need a release sooner of the package please reach out and I'll trigger a release manually.
+
+This script gathers the HSTS Preload list by monitoring
+[this file in the Chromium repository](https://chromium.googlesource.com/chromium/src/+/main/net/http/transport_security_state_static.json). Changes to the HSTS Preload list can be seen in the history of that file.
+
+## License
+
+BSD-3
+
+
+%package help
+Summary: Development documents and examples for hstspreload
+Provides: python3-hstspreload-doc
+%description help
+# hstspreload
+
+
+[![Version](https://img.shields.io/pypi/v/hstspreload)](https://pypi.org/project/hstspreload)
+[![Downloads](https://pepy.tech/badge/hstspreload)](https://pepy.tech/project/hstspreload)
+![CI](https://img.shields.io/github/workflow/status/sethmlarson/hstspreload/CI/master)
+
+Chromium HSTS Preload list as a Python package.
+
+Install via `python -m pip install hstspreload`
+
+See https://hstspreload.org for more information regarding the list itself.
+
+## API
+
+The package provides a single function: `in_hsts_preload()` which takes an
+IDNA-encoded host and returns either `True` or `False` regarding whether
+that host should be only accessed via HTTPS.
+
+## Changelog
+
+This package is built entirely by an automated script running once a month.
+If you need a release sooner of the package please reach out and I'll trigger a release manually.
+
+This script gathers the HSTS Preload list by monitoring
+[this file in the Chromium repository](https://chromium.googlesource.com/chromium/src/+/main/net/http/transport_security_state_static.json). Changes to the HSTS Preload list can be seen in the history of that file.
+
+## License
+
+BSD-3
+
+
+%prep
+%autosetup -n hstspreload-2023.1.1
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-hstspreload -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Sat Feb 25 2023 Python_Bot <Python_Bot@openeuler.org> - 2023.1.1-1
+- Package Spec generated