summaryrefslogtreecommitdiff
path: root/python-html2text.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-html2text.spec')
-rw-r--r--python-html2text.spec335
1 files changed, 335 insertions, 0 deletions
diff --git a/python-html2text.spec b/python-html2text.spec
new file mode 100644
index 0000000..407ed81
--- /dev/null
+++ b/python-html2text.spec
@@ -0,0 +1,335 @@
+%global _empty_manifest_terminate_build 0
+Name: python-html2text
+Version: 2020.1.16
+Release: 1
+Summary: Turn HTML into equivalent Markdown-structured text.
+License: GNU GPL 3
+URL: https://github.com/Alir3z4/html2text/
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/6c/f9/033a17d8ea8181aee41f20c74c3b20f1ccbefbbc3f7cd24e3692de99fb25/html2text-2020.1.16.tar.gz
+BuildArch: noarch
+
+
+%description
+# html2text
+
+[![Build Status](https://secure.travis-ci.org/Alir3z4/html2text.png)](https://travis-ci.org/Alir3z4/html2text)
+[![Coverage Status](https://coveralls.io/repos/Alir3z4/html2text/badge.png)](https://coveralls.io/r/Alir3z4/html2text)
+[![Downloads](http://badge.kloud51.com/pypi/d/html2text.png)](https://pypi.org/project/html2text/)
+[![Version](http://badge.kloud51.com/pypi/v/html2text.png)](https://pypi.org/project/html2text/)
+[![Wheel?](http://badge.kloud51.com/pypi/wheel/html2text.png)](https://pypi.org/project/html2text/)
+[![Format](http://badge.kloud51.com/pypi/format/html2text.png)](https://pypi.org/project/html2text/)
+[![License](http://badge.kloud51.com/pypi/license/html2text.png)](https://pypi.org/project/html2text/)
+
+
+html2text is a Python script that converts a page of HTML into clean, easy-to-read plain ASCII text. Better yet, that ASCII also happens to be valid Markdown (a text-to-HTML format).
+
+
+Usage: `html2text [filename [encoding]]`
+
+| Option | Description
+|--------------------------------------------------------|---------------------------------------------------
+| `--version` | Show program's version number and exit
+| `-h`, `--help` | Show this help message and exit
+| `--ignore-links` | Don't include any formatting for links
+|`--escape-all` | Escape all special characters. Output is less readable, but avoids corner case formatting issues.
+| `--reference-links` | Use reference links instead of links to create markdown
+| `--mark-code` | Mark preformatted and code blocks with [code]...[/code]
+
+For a complete list of options see the [docs](https://github.com/Alir3z4/html2text/blob/master/docs/usage.md)
+
+
+Or you can use it from within `Python`:
+
+```
+>>> import html2text
+>>>
+>>> print(html2text.html2text("<p><strong>Zed's</strong> dead baby, <em>Zed's</em> dead.</p>"))
+**Zed's** dead baby, _Zed's_ dead.
+
+```
+
+
+Or with some configuration options:
+```
+>>> import html2text
+>>>
+>>> h = html2text.HTML2Text()
+>>> # Ignore converting links from HTML
+>>> h.ignore_links = True
+>>> print h.handle("<p>Hello, <a href='https://www.google.com/earth/'>world</a>!")
+Hello, world!
+
+>>> print(h.handle("<p>Hello, <a href='https://www.google.com/earth/'>world</a>!"))
+
+Hello, world!
+
+>>> # Don't Ignore links anymore, I like links
+>>> h.ignore_links = False
+>>> print(h.handle("<p>Hello, <a href='https://www.google.com/earth/'>world</a>!"))
+Hello, [world](https://www.google.com/earth/)!
+
+```
+
+*Originally written by Aaron Swartz. This code is distributed under the GPLv3.*
+
+
+## How to install
+
+`html2text` is available on pypi
+https://pypi.org/project/html2text/
+
+```
+$ pip install html2text
+```
+
+
+## How to run unit tests
+
+ tox
+
+To see the coverage results:
+
+ coverage html
+
+then open the `./htmlcov/index.html` file in your browser.
+
+## Documentation
+
+Documentation lives [here](https://github.com/Alir3z4/html2text/blob/master/docs/usage.md)
+
+
+
+
+%package -n python3-html2text
+Summary: Turn HTML into equivalent Markdown-structured text.
+Provides: python-html2text
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+%description -n python3-html2text
+# html2text
+
+[![Build Status](https://secure.travis-ci.org/Alir3z4/html2text.png)](https://travis-ci.org/Alir3z4/html2text)
+[![Coverage Status](https://coveralls.io/repos/Alir3z4/html2text/badge.png)](https://coveralls.io/r/Alir3z4/html2text)
+[![Downloads](http://badge.kloud51.com/pypi/d/html2text.png)](https://pypi.org/project/html2text/)
+[![Version](http://badge.kloud51.com/pypi/v/html2text.png)](https://pypi.org/project/html2text/)
+[![Wheel?](http://badge.kloud51.com/pypi/wheel/html2text.png)](https://pypi.org/project/html2text/)
+[![Format](http://badge.kloud51.com/pypi/format/html2text.png)](https://pypi.org/project/html2text/)
+[![License](http://badge.kloud51.com/pypi/license/html2text.png)](https://pypi.org/project/html2text/)
+
+
+html2text is a Python script that converts a page of HTML into clean, easy-to-read plain ASCII text. Better yet, that ASCII also happens to be valid Markdown (a text-to-HTML format).
+
+
+Usage: `html2text [filename [encoding]]`
+
+| Option | Description
+|--------------------------------------------------------|---------------------------------------------------
+| `--version` | Show program's version number and exit
+| `-h`, `--help` | Show this help message and exit
+| `--ignore-links` | Don't include any formatting for links
+|`--escape-all` | Escape all special characters. Output is less readable, but avoids corner case formatting issues.
+| `--reference-links` | Use reference links instead of links to create markdown
+| `--mark-code` | Mark preformatted and code blocks with [code]...[/code]
+
+For a complete list of options see the [docs](https://github.com/Alir3z4/html2text/blob/master/docs/usage.md)
+
+
+Or you can use it from within `Python`:
+
+```
+>>> import html2text
+>>>
+>>> print(html2text.html2text("<p><strong>Zed's</strong> dead baby, <em>Zed's</em> dead.</p>"))
+**Zed's** dead baby, _Zed's_ dead.
+
+```
+
+
+Or with some configuration options:
+```
+>>> import html2text
+>>>
+>>> h = html2text.HTML2Text()
+>>> # Ignore converting links from HTML
+>>> h.ignore_links = True
+>>> print h.handle("<p>Hello, <a href='https://www.google.com/earth/'>world</a>!")
+Hello, world!
+
+>>> print(h.handle("<p>Hello, <a href='https://www.google.com/earth/'>world</a>!"))
+
+Hello, world!
+
+>>> # Don't Ignore links anymore, I like links
+>>> h.ignore_links = False
+>>> print(h.handle("<p>Hello, <a href='https://www.google.com/earth/'>world</a>!"))
+Hello, [world](https://www.google.com/earth/)!
+
+```
+
+*Originally written by Aaron Swartz. This code is distributed under the GPLv3.*
+
+
+## How to install
+
+`html2text` is available on pypi
+https://pypi.org/project/html2text/
+
+```
+$ pip install html2text
+```
+
+
+## How to run unit tests
+
+ tox
+
+To see the coverage results:
+
+ coverage html
+
+then open the `./htmlcov/index.html` file in your browser.
+
+## Documentation
+
+Documentation lives [here](https://github.com/Alir3z4/html2text/blob/master/docs/usage.md)
+
+
+
+
+%package help
+Summary: Development documents and examples for html2text
+Provides: python3-html2text-doc
+%description help
+# html2text
+
+[![Build Status](https://secure.travis-ci.org/Alir3z4/html2text.png)](https://travis-ci.org/Alir3z4/html2text)
+[![Coverage Status](https://coveralls.io/repos/Alir3z4/html2text/badge.png)](https://coveralls.io/r/Alir3z4/html2text)
+[![Downloads](http://badge.kloud51.com/pypi/d/html2text.png)](https://pypi.org/project/html2text/)
+[![Version](http://badge.kloud51.com/pypi/v/html2text.png)](https://pypi.org/project/html2text/)
+[![Wheel?](http://badge.kloud51.com/pypi/wheel/html2text.png)](https://pypi.org/project/html2text/)
+[![Format](http://badge.kloud51.com/pypi/format/html2text.png)](https://pypi.org/project/html2text/)
+[![License](http://badge.kloud51.com/pypi/license/html2text.png)](https://pypi.org/project/html2text/)
+
+
+html2text is a Python script that converts a page of HTML into clean, easy-to-read plain ASCII text. Better yet, that ASCII also happens to be valid Markdown (a text-to-HTML format).
+
+
+Usage: `html2text [filename [encoding]]`
+
+| Option | Description
+|--------------------------------------------------------|---------------------------------------------------
+| `--version` | Show program's version number and exit
+| `-h`, `--help` | Show this help message and exit
+| `--ignore-links` | Don't include any formatting for links
+|`--escape-all` | Escape all special characters. Output is less readable, but avoids corner case formatting issues.
+| `--reference-links` | Use reference links instead of links to create markdown
+| `--mark-code` | Mark preformatted and code blocks with [code]...[/code]
+
+For a complete list of options see the [docs](https://github.com/Alir3z4/html2text/blob/master/docs/usage.md)
+
+
+Or you can use it from within `Python`:
+
+```
+>>> import html2text
+>>>
+>>> print(html2text.html2text("<p><strong>Zed's</strong> dead baby, <em>Zed's</em> dead.</p>"))
+**Zed's** dead baby, _Zed's_ dead.
+
+```
+
+
+Or with some configuration options:
+```
+>>> import html2text
+>>>
+>>> h = html2text.HTML2Text()
+>>> # Ignore converting links from HTML
+>>> h.ignore_links = True
+>>> print h.handle("<p>Hello, <a href='https://www.google.com/earth/'>world</a>!")
+Hello, world!
+
+>>> print(h.handle("<p>Hello, <a href='https://www.google.com/earth/'>world</a>!"))
+
+Hello, world!
+
+>>> # Don't Ignore links anymore, I like links
+>>> h.ignore_links = False
+>>> print(h.handle("<p>Hello, <a href='https://www.google.com/earth/'>world</a>!"))
+Hello, [world](https://www.google.com/earth/)!
+
+```
+
+*Originally written by Aaron Swartz. This code is distributed under the GPLv3.*
+
+
+## How to install
+
+`html2text` is available on pypi
+https://pypi.org/project/html2text/
+
+```
+$ pip install html2text
+```
+
+
+## How to run unit tests
+
+ tox
+
+To see the coverage results:
+
+ coverage html
+
+then open the `./htmlcov/index.html` file in your browser.
+
+## Documentation
+
+Documentation lives [here](https://github.com/Alir3z4/html2text/blob/master/docs/usage.md)
+
+
+
+
+%prep
+%autosetup -n html2text-2020.1.16
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-html2text -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Sat Feb 25 2023 Python_Bot <Python_Bot@openeuler.org> - 2020.1.16-1
+- Package Spec generated