summaryrefslogtreecommitdiff
path: root/python-kazoo.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-kazoo.spec')
-rw-r--r--python-kazoo.spec104
1 files changed, 104 insertions, 0 deletions
diff --git a/python-kazoo.spec b/python-kazoo.spec
new file mode 100644
index 0000000..604869b
--- /dev/null
+++ b/python-kazoo.spec
@@ -0,0 +1,104 @@
+%global _empty_manifest_terminate_build 0
+Name: python-kazoo
+Version: 2.9.0
+Release: 1
+Summary: "Higher Level Zookeeper Client"
+License: Apache 2.0
+URL: https://kazoo.readthedocs.io
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/e2/57/3da88c2fdc94bf2976df72d2dcfad3655ab64fa3fd5879b39d174c7e5993/kazoo-2.9.0.tar.gz
+BuildArch: noarch
+
+Requires: python3-six
+Requires: python3-selectors2
+Requires: python3-flake8
+Requires: python3-eventlet
+Requires: python3-gevent
+Requires: python3-pure-sasl
+Requires: python3-Sphinx
+Requires: python3-flake8
+Requires: python3-Sphinx
+Requires: python3-eventlet
+Requires: python3-gevent
+Requires: python3-pure-sasl
+Requires: python3-mock
+Requires: python3-objgraph
+Requires: python3-pytest
+Requires: python3-pytest-cov
+Requires: python3-gevent
+Requires: python3-eventlet
+
+%description
+[![Build Status](https://travis-ci.org/python-zk/kazoo.svg?branch=master)](https://travis-ci.org/python-zk/kazoo)
+[![Latest Version](https://img.shields.io/pypi/v/kazoo.svg)](https://pypi.org/project/kazoo/)
+[![Reviewed by Hound](https://img.shields.io/badge/Reviewed_by-Hound-8E64B0.svg)](https://houndci.com)
+`kazoo` implements a higher level API to [Apache
+Zookeeper](http://zookeeper.apache.org/) for Python clients.
+See [the full docs](http://kazoo.rtfd.org/) for more information.
+
+%package -n python3-kazoo
+Summary: "Higher Level Zookeeper Client"
+Provides: python-kazoo
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+%description -n python3-kazoo
+[![Build Status](https://travis-ci.org/python-zk/kazoo.svg?branch=master)](https://travis-ci.org/python-zk/kazoo)
+[![Latest Version](https://img.shields.io/pypi/v/kazoo.svg)](https://pypi.org/project/kazoo/)
+[![Reviewed by Hound](https://img.shields.io/badge/Reviewed_by-Hound-8E64B0.svg)](https://houndci.com)
+`kazoo` implements a higher level API to [Apache
+Zookeeper](http://zookeeper.apache.org/) for Python clients.
+See [the full docs](http://kazoo.rtfd.org/) for more information.
+
+%package help
+Summary: Development documents and examples for kazoo
+Provides: python3-kazoo-doc
+%description help
+[![Build Status](https://travis-ci.org/python-zk/kazoo.svg?branch=master)](https://travis-ci.org/python-zk/kazoo)
+[![Latest Version](https://img.shields.io/pypi/v/kazoo.svg)](https://pypi.org/project/kazoo/)
+[![Reviewed by Hound](https://img.shields.io/badge/Reviewed_by-Hound-8E64B0.svg)](https://houndci.com)
+`kazoo` implements a higher level API to [Apache
+Zookeeper](http://zookeeper.apache.org/) for Python clients.
+See [the full docs](http://kazoo.rtfd.org/) for more information.
+
+%prep
+%autosetup -n kazoo-2.9.0
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-kazoo -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Sat Feb 25 2023 Python_Bot <Python_Bot@openeuler.org> - 2.9.0-1
+- Package Spec generated