summaryrefslogtreecommitdiff
path: root/python-notebook.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-notebook.spec')
-rw-r--r--python-notebook.spec128
1 files changed, 128 insertions, 0 deletions
diff --git a/python-notebook.spec b/python-notebook.spec
new file mode 100644
index 0000000..ab4b73a
--- /dev/null
+++ b/python-notebook.spec
@@ -0,0 +1,128 @@
+%global _empty_manifest_terminate_build 0
+Name: python-notebook
+Version: 6.5.2
+Release: 1
+Summary: A web-based notebook environment for interactive computing
+License: BSD
+URL: http://jupyter.org
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/41/15/a4285abb25c87dec3002cd7eab88320ef21448effdd3714840695aafab12/notebook-6.5.2.tar.gz
+BuildArch: noarch
+
+Requires: python3-jinja2
+Requires: python3-tornado
+Requires: python3-pyzmq
+Requires: python3-argon2-cffi
+Requires: python3-traitlets
+Requires: python3-jupyter-core
+Requires: python3-jupyter-client
+Requires: python3-ipython-genutils
+Requires: python3-nbformat
+Requires: python3-nbconvert
+Requires: python3-nest-asyncio
+Requires: python3-ipykernel
+Requires: python3-Send2Trash
+Requires: python3-terminado
+Requires: python3-prometheus-client
+Requires: python3-nbclassic
+Requires: python3-sphinx
+Requires: python3-nbsphinx
+Requires: python3-sphinxcontrib-github-alt
+Requires: python3-sphinx-rtd-theme
+Requires: python3-myst-parser
+Requires: python3-json-logging
+Requires: python3-pytest
+Requires: python3-coverage
+Requires: python3-requests
+Requires: python3-testpath
+Requires: python3-nbval
+Requires: python3-selenium
+Requires: python3-pytest-cov
+Requires: python3-requests-unixsocket
+
+%description
+
+The Jupyter Notebook is a web application that allows you to create and
+share documents that contain live code, equations, visualizations, and
+explanatory text. The Notebook has support for multiple programming
+languages, sharing, and interactive widgets.
+
+Read `the documentation <https://jupyter-notebook.readthedocs.io>`_
+for more information.
+
+
+
+%package -n python3-notebook
+Summary: A web-based notebook environment for interactive computing
+Provides: python-notebook
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+%description -n python3-notebook
+
+The Jupyter Notebook is a web application that allows you to create and
+share documents that contain live code, equations, visualizations, and
+explanatory text. The Notebook has support for multiple programming
+languages, sharing, and interactive widgets.
+
+Read `the documentation <https://jupyter-notebook.readthedocs.io>`_
+for more information.
+
+
+
+%package help
+Summary: Development documents and examples for notebook
+Provides: python3-notebook-doc
+%description help
+
+The Jupyter Notebook is a web application that allows you to create and
+share documents that contain live code, equations, visualizations, and
+explanatory text. The Notebook has support for multiple programming
+languages, sharing, and interactive widgets.
+
+Read `the documentation <https://jupyter-notebook.readthedocs.io>`_
+for more information.
+
+
+
+%prep
+%autosetup -n notebook-6.5.2
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-notebook -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Sat Feb 25 2023 Python_Bot <Python_Bot@openeuler.org> - 6.5.2-1
+- Package Spec generated