summaryrefslogtreecommitdiff
path: root/python-parso.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-parso.spec')
-rw-r--r--python-parso.spec84
1 files changed, 84 insertions, 0 deletions
diff --git a/python-parso.spec b/python-parso.spec
new file mode 100644
index 0000000..cb22209
--- /dev/null
+++ b/python-parso.spec
@@ -0,0 +1,84 @@
+%global _empty_manifest_terminate_build 0
+Name: python-parso
+Version: 0.8.3
+Release: 1
+Summary: A Python Parser
+License: MIT
+URL: https://github.com/davidhalter/parso
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/a2/0e/41f0cca4b85a6ea74d66d2226a7cda8e41206a624f5b330b958ef48e2e52/parso-0.8.3.tar.gz
+BuildArch: noarch
+
+Requires: python3-flake8
+Requires: python3-mypy
+Requires: python3-docopt
+Requires: python3-pytest
+
+%description
+- `Testing <https://parso.readthedocs.io/en/latest/docs/development.html#testing>`_
+- `PyPI <https://pypi.python.org/pypi/parso>`_
+- `Docs <https://parso.readthedocs.org/en/latest/>`_
+- Uses `semantic versioning <https://semver.org/>`_
+
+%package -n python3-parso
+Summary: A Python Parser
+Provides: python-parso
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+%description -n python3-parso
+- `Testing <https://parso.readthedocs.io/en/latest/docs/development.html#testing>`_
+- `PyPI <https://pypi.python.org/pypi/parso>`_
+- `Docs <https://parso.readthedocs.org/en/latest/>`_
+- Uses `semantic versioning <https://semver.org/>`_
+
+%package help
+Summary: Development documents and examples for parso
+Provides: python3-parso-doc
+%description help
+- `Testing <https://parso.readthedocs.io/en/latest/docs/development.html#testing>`_
+- `PyPI <https://pypi.python.org/pypi/parso>`_
+- `Docs <https://parso.readthedocs.org/en/latest/>`_
+- Uses `semantic versioning <https://semver.org/>`_
+
+%prep
+%autosetup -n parso-0.8.3
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-parso -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Sat Feb 25 2023 Python_Bot <Python_Bot@openeuler.org> - 0.8.3-1
+- Package Spec generated