summaryrefslogtreecommitdiff
path: root/rubygem-unicode-display_width.spec
diff options
context:
space:
mode:
Diffstat (limited to 'rubygem-unicode-display_width.spec')
-rw-r--r--rubygem-unicode-display_width.spec75
1 files changed, 75 insertions, 0 deletions
diff --git a/rubygem-unicode-display_width.spec b/rubygem-unicode-display_width.spec
new file mode 100644
index 0000000..ec6e4eb
--- /dev/null
+++ b/rubygem-unicode-display_width.spec
@@ -0,0 +1,75 @@
+%global _empty_manifest_terminate_build 0
+%global gem_name unicode-display_width
+Name: rubygem-unicode-display_width
+Version: 2.4.2
+Release: 1
+Summary: Determines the monospace display width of a string in Ruby.
+License: MIT
+URL: https://github.com/janlelis/unicode-display_width
+Source0: https://rubygems.org/gems/unicode-display_width-2.4.2.gem
+BuildArch: noarch
+
+BuildRequires: ruby
+BuildRequires: ruby-devel
+BuildRequires: rubygems
+BuildRequires: rubygems-devel
+BuildRequires: rsync
+Provides: rubygem-unicode-display_width
+
+%description
+[Unicode 15.0.0] Determines the monospace display width of a string using EastAsianWidth.txt, Unicode general category, and other data.
+
+%package help
+Summary: Development documents and examples for unicode-display_width
+Provides: rubygem-unicode-display_width-doc
+BuildArch: noarch
+
+%description help
+[Unicode 15.0.0] Determines the monospace display width of a string using EastAsianWidth.txt, Unicode general category, and other data.
+
+%prep
+%autosetup -n unicode-display_width-2.4.2
+gem spec %{SOURCE0} -l --ruby > unicode-display_width.gemspec
+
+%build
+gem build unicode-display_width.gemspec
+%gem_install
+
+%install
+mkdir -p %{buildroot}%{gem_dir}
+cp -a .%{gem_dir}/* %{buildroot}%{gem_dir}/
+rsync -a --exclude=".*" .%{gem_dir}/* %{buildroot}%{gem_dir}/
+if [ -d .%{_bindir} ]; then
+ mkdir -p %{buildroot}%{_bindir}
+ cp -a .%{_bindir}/* %{buildroot}%{_bindir}/
+fi
+if [ -d ext ]; then
+ mkdir -p %{buildroot}%{gem_extdir_mri}/%{gem_name}
+ if [ -d .%{gem_extdir_mri}/%{gem_name} ]; then
+ cp -a .%{gem_extdir_mri}/%{gem_name}/*.so %{buildroot}%{gem_extdir_mri}/%{gem_name}
+ else
+ cp -a .%{gem_extdir_mri}/*.so %{buildroot}%{gem_extdir_mri}/%{gem_name}
+fi
+ cp -a .%{gem_extdir_mri}/gem.build_complete %{buildroot}%{gem_extdir_mri}/
+ rm -rf %{buildroot}%{gem_instdir}/ext/
+fi
+pushd %{buildroot}
+touch filelist.lst
+if [ -d %{buildroot}%{_bindir} ]; then
+ find .%{_bindir} -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+
+%files -n rubygem-unicode-display_width -f filelist.lst
+%dir %{gem_instdir}
+%{gem_instdir}/*
+%exclude %{gem_cache}
+%{gem_spec}
+
+%files help
+%{gem_docdir}/*
+
+%changelog
+* Fri Mar 10 2023 Ruby_Bot <Ruby_Bot@openeuler.org>
+- Package Spec generated