summaryrefslogtreecommitdiff
path: root/python-uvicorn.spec
diff options
context:
space:
mode:
authorCoprDistGit <infra@openeuler.org>2024-10-25 21:55:41 +0000
committerCoprDistGit <infra@openeuler.org>2024-10-25 21:55:41 +0000
commitaf8813e56b815b23d573054085b76623fed3b26a (patch)
tree57dba12ff5738cf032cb56c8bebd132b6a99952c /python-uvicorn.spec
parent7bbe4c639673f6f72cc329d29cd4f9765a6ca1e3 (diff)
automatic import of python-uvicornopeneuler24.03_LTS
Diffstat (limited to 'python-uvicorn.spec')
-rw-r--r--python-uvicorn.spec70
1 files changed, 70 insertions, 0 deletions
diff --git a/python-uvicorn.spec b/python-uvicorn.spec
new file mode 100644
index 0000000..6e7c489
--- /dev/null
+++ b/python-uvicorn.spec
@@ -0,0 +1,70 @@
+%global pkgname uvicorn
+
+Name: python-%{pkgname}
+Version: 0.30.1
+Release: 1
+Summary: The lightning-fast ASGI server
+License: BSD
+URL: https://www.uvicorn.org
+Source0: https://files.pythonhosted.org/packages/37/16/9f5ccaa1a76e5bfbaa0c67640e2db8a5214ca08d92a1b427fa1677b3da88/uvicorn-0.30.1.tar.gz
+BuildArch: noarch
+
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+BuildRequires: python3-wheel
+BuildRequires: python3-hatchling
+BuildRequires: python3-httptools
+BuildRequires: python3-dotenv
+BuildRequires: python3-PyYAML
+BuildRequires: python3-uvloop
+BuildRequires: python3-websockets
+
+%description
+Uvicorn is an ASGI web server implementation for Python.
+Until recently Python has lacked a minimal low-level server/application interface for async frameworks.
+The ASGI specification fills this gap, and means we're now able to start building a common set of tooling
+usable across all async frameworks.
+Uvicorn supports HTTP/1.1 and WebSockets.
+
+%package -n python3-%{pkgname}
+Summary: %{summary}
+
+%description -n python3-%{pkgname}
+Uvicorn is an ASGI web server implementation for Python.
+Until recently Python has lacked a minimal low-level server/application interface for async frameworks.
+The ASGI specification fills this gap, and means we're now able to start building a common set of tooling
+usable across all async frameworks.
+Uvicorn supports HTTP/1.1 and WebSockets.
+
+%prep
+%autosetup -n uvicorn-%{version} -p 1
+
+%build
+%pyproject_build
+
+%install
+%pyproject_install
+
+%files -n python3-%{pkgname}
+%license LICENSE.md
+%doc README.md
+%{_bindir}/uvicorn
+%{python3_sitelib}/uvicorn*.dist-info/
+%{python3_sitelib}/uvicorn
+
+%changelog
+* Fri Jun 28 2024 liyue01 <liyue01@kylinos.cn> - 0.30.1-1
+- Update package to version 0.30.1
+- Fixed :Allow horizontal tabs in response header values
+- Added New multiprocess manager and Allow ConfigParser or a io.IO[Any] on log_config
+- Fixed:Suppress side-effects of signal propagation ,Send content-length header on 5xx
+- Added Cooperative signal handling
+- Fixed :Revert raise ClientDisconnected on HTTP
+- Added Raise ClientDisconnected on send() when client disconnected
+
+* Mon Feb 26 2024 wangjunqi <wangjunqi@kylinos.cn> - 0.27.1-1
+- Update package to version 0.27.1
+
+* Tue Jul 25 2023 ysliu <ysliuci@isoftstone.com> - 0.23.1-1
+- Initial package.