summaryrefslogtreecommitdiff
path: root/vpcs.spec
diff options
context:
space:
mode:
Diffstat (limited to 'vpcs.spec')
-rw-r--r--vpcs.spec55
1 files changed, 55 insertions, 0 deletions
diff --git a/vpcs.spec b/vpcs.spec
new file mode 100644
index 0000000..b5f6c9b
--- /dev/null
+++ b/vpcs.spec
@@ -0,0 +1,55 @@
+
+Name: vpcs
+Version: 0.8.3
+Release: 1%{?dist}
+Summary: Virtual PC Simulator
+
+License: BSD
+URL: https://github.com/GNS3/vpcs
+Source0: http://downloads.sourceforge.net/project/%{name}/%{version}/%{name}-%{version}.tar.gz
+
+BuildRequires: make
+BuildRequires: gcc
+
+%description
+The VPCS can simulate up to 9 PCs. You can ping/traceroute them, or
+ping/traceroute the other hosts/routers from the VPCS
+
+
+%prep
+%autosetup -p1
+
+
+%build
+sed -e 's/^CFLAGS=.*$/CFLAGS:=$(CFLAGS) -D$(OSTYPE) -D$(CPUTYPE) $(OPT) $(HVOPT) -Wall -I. -DTAP/' \
+ -e 's/^LDFLAGS=.*$/LDFLAGS:=$(LDFLAGS) -lpthread -lutil/' \
+ -i src/Makefile.linux
+mv src/Makefile.linux src/Makefile
+cd src/
+%make_build %{?_smp_mflags} CFLAGS="%{optflags} -DHV -DTAP -DLinux"
+
+%install
+mkdir -p %{buildroot}/%{_bindir} %{buildroot}/%{_mandir}/man1/
+install -m 755 src/vpcs %{buildroot}/%{_bindir}
+install -m 644 man/vpcs.1 %{buildroot}/%{_mandir}/man1/
+
+%files
+%license COPYING
+%{_bindir}/*
+%{_mandir}/man1/*
+%doc readme.txt
+
+
+
+%changelog
+* Thu Dec 01 2016 Athmane Madjoudj <athmane@fedoraproject.org> - 0.8-3
+- Fix Source url
+
+* Tue Sep 27 2016 Athmane Madjoudj <athmane@fedoraproject.org> - 0.8.0.20160224svn-2
+- Fix version
+
+* Sat Sep 10 2016 Athmane Madjoudj <athmane@fedoraproject.org> - 0.8.0svn126-1
+- Update to latest svn rev to fix some bugs
+
+* Sat Sep 10 2016 Athmane Madjoudj <athmane@fedoraproject.org> - 0.8-1
+- Initial spec