summaryrefslogtreecommitdiff
path: root/llama.cpp.spec
diff options
context:
space:
mode:
Diffstat (limited to 'llama.cpp.spec')
-rw-r--r--llama.cpp.spec17
1 files changed, 7 insertions, 10 deletions
diff --git a/llama.cpp.spec b/llama.cpp.spec
index dca8d78..3c810fd 100644
--- a/llama.cpp.spec
+++ b/llama.cpp.spec
@@ -1,15 +1,17 @@
%define debug_package %{nil}
-%global llama_commitid b4034
+%global llama_commitid b3051
Name: llama.cpp
-Version: 20241105
-Release: 1
+Version: 20240531
+Release: 2
License: MIT
Summary: Port of English lagre model LLaMA implemented based on C/C++
URL: https://github.com/ggerganov/llama.cpp
Source0: https://github.com/ggerganov/llama.cpp/archive/refs/tags/%{llama_commitid}.tar.gz
+Patch6000: backport-CVE-2024-41130.patch
+Patch6001: backport-CVE-2024-42477-CVE-2024-42478-CVE-2024-42479.patch
BuildRequires: gcc,gcc-c++,cmake
@@ -30,22 +32,17 @@ popd
%install
pushd llama_builddir
%make_install
-mv %{buildroot}%{_prefix}/local/bin/llama-cli %{buildroot}%{_prefix}/local/bin/llama_cpp_main
-mv %{buildroot}%{_prefix}/local/bin/convert_hf_to_gguf.py %{buildroot}%{_prefix}/local/bin/llama_convert_hf_to_gguf.py
+mv %{buildroot}%{_prefix}/local/bin/main %{buildroot}%{_prefix}/local/bin/llama_cpp_main
+mv %{buildroot}%{_prefix}/local/bin/convert-hf-to-gguf.py %{buildroot}%{_prefix}/local/bin/llama_convert-hf-to-gguf.py
mv %{buildroot}%{_prefix}/local/* %{buildroot}%{_prefix}
-mv %{buildroot}%{_prefix}/lib/pkgconfig/llama.pc %{buildroot}%{_prefix}
popd
%files
%{_bindir}/*
%{_includedir}/*
%{_libdir}/*
-%{_prefix}/llama.pc
%changelog
-* Tue Nov 05 2024 lifan <lifan140@h-partners.com> - 20241105-1
-- update llama.cpp to b4034
-
* Wed Aug 28 2024 zhoupengcheng <zhoupengcheng11@huawei.com> - 20240531-2
- fix CVE-2024-42477,CVE-2024-42478,CVE-2024-42479.patch,CVE-2024-41130