summaryrefslogtreecommitdiff
path: root/libgmem.spec
diff options
context:
space:
mode:
Diffstat (limited to 'libgmem.spec')
-rw-r--r--libgmem.spec20
1 files changed, 18 insertions, 2 deletions
diff --git a/libgmem.spec b/libgmem.spec
index ee6cc16..de6d188 100644
--- a/libgmem.spec
+++ b/libgmem.spec
@@ -1,6 +1,8 @@
+%define gmem_path /usr/local/gmem
+
Name: libgmem
Version: 0.1
-Release: 3
+Release: 5
Summary: Library of Generalized Memory Management
License: MulanPSL-2.0
URL: https://gitee.com/openeuler/libgmem
@@ -8,9 +10,12 @@ Source0: https://gitee.com/openeuler/libgmem/repository/archive/%{name}-v
PATCH0001: use-ioctl-instead-of-syscall.patch
PATCH0002: fix-three-issue-I7YV2X-I7XQMW-I7Z2RF.patch
+Patch0003: Structures-and-macros-use-the-default-definition-of-.patch
+Patch0004: optimize-headers-file.patch
+Patch0005: add-install_npu_driver.sh.patch
BuildRequires: autoconf automake libtool
-BuildRequires: gcc glibc-devel make
+BuildRequires: gcc glibc-devel make kernel-headers
%description
libgmem is the abstract layer of GMEM(Generalized Memory Management) user-mode interface,
@@ -32,6 +37,8 @@ sh ./autogen.sh
%make_build
%install
+install -dp %{buildroot}/%{gmem_path}
+install -Dp %{_builddir}/%{name}-v%{version}/scripts/install_npu_driver.sh %{buildroot}/%{gmem_path}/
%make_install
%delete_la
@@ -44,8 +51,17 @@ sh ./autogen.sh
%files devel
%{_includedir}/libgmem.h
+%dir %{gmem_path}
+%{gmem_path}/install_npu_driver.sh
%changelog
+* Wed Sep 20 2023 Lemmy Huang <huangliming5@huawei.com> - 0.1-5
+- add install_npu_driver.sh
+
+* Tue Sep 12 2023 Yang Yanchao <yangyanchao6@huawei.com> - 0.1-4
+- Structures and macros use the default definition of the kernel [I80K89]
+ optimize headers file
+
* Wed Sep 06 2023 Yang Yanchao <yangyanchao6@huawei.com> - 0.1-3
- Check the return ptr of the malloc[#I7YV2X]
add hnid in gmemPrefetch [#I7XQMW]