summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCoprDistGit <infra@openeuler.org>2023-08-26 06:24:52 +0000
committerCoprDistGit <infra@openeuler.org>2023-08-26 06:24:52 +0000
commitb30e39f55a1fcdc0273d3d6fc59f79ca69f3315d (patch)
tree3f4ca28e39f902634224ee319d0f734331d1fe4b
parentc6cbe4f9a68e4fb17e1ebcc6ef3ee01456046aa0 (diff)
automatic import of python-anyascii
-rw-r--r--python-anyascii.spec147
1 files changed, 119 insertions, 28 deletions
diff --git a/python-anyascii.spec b/python-anyascii.spec
index d067f28..c55bc64 100644
--- a/python-anyascii.spec
+++ b/python-anyascii.spec
@@ -1,47 +1,138 @@
-%global pypi_name anyascii
-
-Name: python-%{pypi_name}
+%global _empty_manifest_terminate_build 0
+Name: python-anyascii
Version: 0.3.2
Release: 1
-Summary: Unicode to ASCII transliteration.
-
-License: MIT
-URL: https://github.com/anyascii/anyascii
-Source0: %{url}/archive/v%{version}/%{pypi_name}-%{version}.tar.gz
+Summary: Unicode to ASCII transliteration
+License: None
+URL: https://pypi.org/project/anyascii/
+Source0: https://mirrors.aliyun.com/pypi/web/packages/9f/52/93b9ea99063f7cf37fb67f5e3f49480686cbe7f228c48b9d713326223b6e/anyascii-0.3.2.tar.gz
BuildArch: noarch
+
%description
-AnyAscii provides ASCII-only replacement strings for practically all Unicode characters. Text is converted character-by-character without considering the context.
+# AnyAscii
+
+Unicode to ASCII transliteration
+
+[**Web Demo**](https://anyascii.com)
+
+Converts Unicode characters to their best ASCII representation
+
+AnyAscii provides ASCII-only replacement strings for practically all Unicode characters. Text is converted character-by-character without considering the context. The mappings for each script are based on popular existing romanization systems. Symbolic characters are converted based on their meaning or appearance. All ASCII characters in the input are left unchanged, every other character is replaced with printable ASCII characters. Unknown characters and some known characters are replaced with an empty string and removed.
+
+```python
+from anyascii import anyascii
+
+s = anyascii('άνθρωποι')
+assert s == 'anthropoi'
+```
-%package -n python3-%{pypi_name}
-Summary: Unicode to ASCII transliteration.
-Provides: python-%{pypi_name}
+Python 3.3+ compatible
+`pip install anyascii`
+
+[**FULL README**](https://github.com/anyascii/anyascii)
+
+
+%package -n python3-anyascii
+Summary: Unicode to ASCII transliteration
+Provides: python-anyascii
BuildRequires: python3-devel
BuildRequires: python3-setuptools
-BuildRequires: python3-setuptools_scm
-BuildRequires: python3-pip
-BuildRequires: python3-wheel
-BuildRequires: python3-flit
+BuildRequires: python3-pip
+%description -n python3-anyascii
+# AnyAscii
+
+Unicode to ASCII transliteration
+
+[**Web Demo**](https://anyascii.com)
+
+Converts Unicode characters to their best ASCII representation
+
+AnyAscii provides ASCII-only replacement strings for practically all Unicode characters. Text is converted character-by-character without considering the context. The mappings for each script are based on popular existing romanization systems. Symbolic characters are converted based on their meaning or appearance. All ASCII characters in the input are left unchanged, every other character is replaced with printable ASCII characters. Unknown characters and some known characters are replaced with an empty string and removed.
+
+```python
+from anyascii import anyascii
+
+s = anyascii('άνθρωποι')
+assert s == 'anthropoi'
+```
+
+Python 3.3+ compatible
+
+`pip install anyascii`
+
+[**FULL README**](https://github.com/anyascii/anyascii)
+
+
+%package help
+Summary: Development documents and examples for anyascii
+Provides: python3-anyascii-doc
+%description help
+# AnyAscii
+
+Unicode to ASCII transliteration
+
+[**Web Demo**](https://anyascii.com)
+
+Converts Unicode characters to their best ASCII representation
+
+AnyAscii provides ASCII-only replacement strings for practically all Unicode characters. Text is converted character-by-character without considering the context. The mappings for each script are based on popular existing romanization systems. Symbolic characters are converted based on their meaning or appearance. All ASCII characters in the input are left unchanged, every other character is replaced with printable ASCII characters. Unknown characters and some known characters are replaced with an empty string and removed.
+
+```python
+from anyascii import anyascii
+
+s = anyascii('άνθρωποι')
+assert s == 'anthropoi'
+```
+
+Python 3.3+ compatible
+
+`pip install anyascii`
+
+[**FULL README**](https://github.com/anyascii/anyascii)
-%description -n python3-%{pypi_name}
-AnyAscii provides ASCII-only replacement strings for practically all Unicode characters. Text is converted character-by-character without considering the context.
%prep
-%autosetup -n %{pypi_name}-%{version}
+%autosetup -n anyascii-0.3.2
%build
-%pyproject_build
+%py3_build
%install
-%pyproject_install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-anyascii -f filelist.lst
+%dir %{python3_sitelib}/*
-%files -n python3-%{pypi_name}
-%license LICENSE
-%doc README.md
-%{python3_sitelib}/anyascii-*.dist-info/
-%{python3_sitelib}/anyascii/
+%files help -f doclist.lst
+%{_docdir}/*
%changelog
-* Mon Aug 21 2023 mengzhaoa <mengzhaoa@isoftstone.com> - 0.3.2-1
-- Init package python-anyascii.
+* Sat Aug 26 2023 Python_Bot <Python_Bot@openeuler.org> - 0.3.2-1
+- Package Spec generated