diff options
author | CoprDistGit <infra@openeuler.org> | 2023-08-22 07:33:20 +0000 |
---|---|---|
committer | CoprDistGit <infra@openeuler.org> | 2023-08-22 07:33:20 +0000 |
commit | 588ddd5682fcca9d3f91989e6275693995757f60 (patch) | |
tree | a5144f9254749a64fb3bd751e8678a41f91ed7fa | |
parent | a2023c0a2d3e2ce48cb7095f95db62253032958e (diff) |
automatic import of python-bump2versionopeneuler23.03
-rw-r--r-- | .gitignore | 1 | ||||
-rw-r--r-- | python-bump2version.spec | 73 | ||||
-rw-r--r-- | sources | 1 |
3 files changed, 75 insertions, 0 deletions
@@ -0,0 +1 @@ +/bump2version-1.0.1.tar.gz diff --git a/python-bump2version.spec b/python-bump2version.spec new file mode 100644 index 0000000..cc143ff --- /dev/null +++ b/python-bump2version.spec @@ -0,0 +1,73 @@ +# Created by pyp2rpm-3.3.9 +%global pypi_name bump2version +%global pypi_version 1.0.1 + +Name: python-%{pypi_name} +Version: %{pypi_version} +Release: 1 +Summary: Version-bump your software with a single command! + +License: MIT +URL: https://github.com/c4urself/bump2version +Source0: https://files.pythonhosted.org/packages/29/2a/688aca6eeebfe8941235be53f4da780c6edee05dbbea5d7abaa3aab6fad2/bump2version-1.0.1.tar.gz +BuildArch: noarch + +BuildRequires: python3-devel +BuildRequires: python3-setuptools +BuildRequires: python3-pip +BuildRequires: python3-wheel +BuildRequires: python3-hatchling + +%description + A small command line tool to simplify releasing software by updating all version strings in your source code by the correct increment. + +%package -n python3-%{pypi_name} +Summary: %{summary} +%{?python_provide:%python_provide python3-%{pypi_name}} + +%package help +Summary: Fix common misspellings in text files. +Provides: python3-%{source_name}-doc +%description help +A small command line tool to simplify releasing software by updating all version strings in your source code by the correct increment. + +Requires: python3dist(setuptools) +%description -n python3-%{pypi_name} +A small command line tool to simplify releasing software by updating all version strings in your source code by the correct increment. + + +%prep +%autosetup -n %{pypi_name}-%{pypi_version} + +%build +%pyproject_build + +%install +%pyproject_install +install -d -m755 %{buildroot}/%{_pkgdocdir} +if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi +if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi +if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi +if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi +pushd %{buildroot} +touch doclist.lst +if [ -d usr/share/man ]; then + find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst +fi +popd +mv %{buildroot}/doclist.lst . + +%files -n python3-%{pypi_name} +%license LICENSE.rst +%doc README.md +%{_bindir}/bump2version +%{_bindir}/bumpversion +%{python3_sitelib}/bumpversion +%{python3_sitelib}/bump2version* + +%files help +%{_docdir}/* + +%changelog +* Fri Aug 18 2023 luolu12 <luluoc@isoftstone.com> - 1.0.1-1 +- Initial package. @@ -0,0 +1 @@ +dd9954741b37da790099efa0695a6874 bump2version-1.0.1.tar.gz |