summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCoprDistGit <infra@openeuler.org>2023-08-22 07:32:50 +0000
committerCoprDistGit <infra@openeuler.org>2023-08-22 07:32:50 +0000
commit2f2a115fcdedfe51162b630634eb93e9cab5b5d3 (patch)
tree65e9ef2f5e6c12cc5971e13aae1e4a9d9d0e37da
parent79715ec8a6e137f09b1d2039144297eaf15e1d5e (diff)
automatic import of python-flake8-comprehensionsopeneuler23.03
-rw-r--r--.gitignore1
-rw-r--r--python-flake8-comprehensions.spec49
-rw-r--r--sources1
3 files changed, 51 insertions, 0 deletions
diff --git a/.gitignore b/.gitignore
index e69de29..a1b4cfc 100644
--- a/.gitignore
+++ b/.gitignore
@@ -0,0 +1 @@
+/flake8_comprehensions-3.14.0.tar.gz
diff --git a/python-flake8-comprehensions.spec b/python-flake8-comprehensions.spec
new file mode 100644
index 0000000..290a2fe
--- /dev/null
+++ b/python-flake8-comprehensions.spec
@@ -0,0 +1,49 @@
+%global _empty_manifest_terminate_build 0
+%global pypi_name flake8-comprehensions
+%global source_name flake8_comprehensions
+
+Name: python-%{pypi_name}
+Version: 3.14.0
+Release: 1
+Summary: A flake8 plugin that helps you write better list/set/dict comprehensions.
+
+License: MIT
+URL: https://github.com/adamchainz/flake8-comprehensions
+Source0: %{url}/archive/%{version}/%{source_name}-%{version}.tar.gz
+BuildArch: noarch
+
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+BuildRequires: python3-wheel
+BuildRequires: python3-hatchling
+BuildRequires: python3-virtualenv
+BuildRequires: python3-poetry-core
+
+%description
+A flake8 plugin that helps you write better list/set/dict comprehensions.
+
+%package -n python3-%{pypi_name}
+Summary: %{summary}
+
+%description -n python3-%{pypi_name}
+A flake8 plugin that helps you write better list/set/dict comprehensions.
+
+%prep
+%autosetup -p1 -n %{source_name}-%{version}
+
+%build
+%pyproject_build
+
+%install
+%pyproject_install
+
+%files -n python3-%{pypi_name}
+%doc README.rst
+%license LICENSE
+%{python3_sitelib}/flake8_comprehensions*.dist-info/
+%{python3_sitelib}/flake8_comprehensions
+
+%changelog
+* Mon Aug 21 2023 zoujiancang<jczou@isoftstone.com> - 3.14.0-1
+- Initial package
diff --git a/sources b/sources
new file mode 100644
index 0000000..0111d88
--- /dev/null
+++ b/sources
@@ -0,0 +1 @@
+10e1042bd65bd1f4b151779f7f6acf82 flake8_comprehensions-3.14.0.tar.gz