diff options
author | CoprDistGit <infra@openeuler.org> | 2023-08-22 08:45:54 +0000 |
---|---|---|
committer | CoprDistGit <infra@openeuler.org> | 2023-08-22 08:45:54 +0000 |
commit | 6453a128988799dd1c604d4cd6dcf56e5f8b03f4 (patch) | |
tree | 19f50a142295b6642bdc03dbe29f21d6220ccccb | |
parent | c8f67c00e51b324d29e9492b418cc1b5753e921f (diff) |
automatic import of python-hatch-jupyter-builderopeneuler23.03
-rw-r--r-- | .gitignore | 1 | ||||
-rw-r--r-- | python-hatch-jupyter-builder.spec | 70 | ||||
-rw-r--r-- | sources | 1 |
3 files changed, 72 insertions, 0 deletions
@@ -0,0 +1 @@ +/hatch_jupyter_builder-0.8.3.tar.gz diff --git a/python-hatch-jupyter-builder.spec b/python-hatch-jupyter-builder.spec new file mode 100644 index 0000000..084ca7e --- /dev/null +++ b/python-hatch-jupyter-builder.spec @@ -0,0 +1,70 @@ +%global pypi_name hatch-jupyter-builder +%global source_name hatch_jupyter_builder +%global pypi_version 0.8.3 + +Name: python-%{pypi_name} +Version: %{pypi_version} +Release: 1 +Summary: This provides a build hook plugin for Hatch that adds a build step for use with Jupyter packages. + +License: BSD-3-Clause +URL: https://github.com/jupyterlab/hatch-jupyter-builder +Source0: https://files.pythonhosted.org/packages/b1/b2/3c304707d4d3c30b2c87f1b8f8b2eb4a682662fea13bd5ab8f16c4c0eb0b/hatch_jupyter_builder-0.8.3.tar.gz +BuildArch: noarch + +BuildRequires: python3-devel +BuildRequires: python3-setuptools +BuildRequires: python3-pip +BuildRequires: python3-wheel +BuildRequires: python3-hatchling + +%description +This provides a build hook plugin for Hatch that adds a build step for use with Jupyter packages. + +%package -n python3-%{source_name} +Summary: %{summary} +%{?python_provide:%python_provide python3-%{source_name}} + +%package help +Summary: Fix common misspellings in text files. +Provides: python3-%{source_name}-doc +%description help +This provides a build hook plugin for Hatch that adds a build step for use with Jupyter packages. + +%description -n python3-%{source_name} +This provides a build hook plugin for Hatch that adds a build step for use with Jupyter packages. + +%prep +%autosetup -n %{source_name}-%{pypi_version} + +%build +%pyproject_build + +%install +%pyproject_install +install -d -m755 %{buildroot}/%{_pkgdocdir} +if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi +if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi +if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi +if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi +pushd %{buildroot} +touch doclist.lst +if [ -d usr/share/man ]; then + find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst +fi +popd +mv %{buildroot}/doclist.lst . + +%files -n python3-%{source_name} +%license LICENSE.txt +%doc README.md +%{python3_sitelib}/hatch_jupyter_builder* +%{_bindir}/hatch-jupyter-builder + + +%files help +%{_docdir}/* + +%changelog +* Thu Aug 17 2023 luolu12 <luluoc@isoftstone.com> - 0.8.3-1 +- Initial package. @@ -0,0 +1 @@ +4d1e53ae27678888aa5e6c7485a33ac4 hatch_jupyter_builder-0.8.3.tar.gz |