summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCoprDistGit <infra@openeuler.org>2023-08-22 09:30:40 +0000
committerCoprDistGit <infra@openeuler.org>2023-08-22 09:30:40 +0000
commit737945bb79d63ff5c109fb69f836602b8341b5d3 (patch)
treeab6dbd6f11b18ebe8d73c66ac33c20d9e1752144
parent36a23bc9b6c04871169dd2b13ac4ba88af1f9eda (diff)
automatic import of python-nox
-rw-r--r--python-nox.spec377
1 files changed, 338 insertions, 39 deletions
diff --git a/python-nox.spec b/python-nox.spec
index 4225167..542cf1a 100644
--- a/python-nox.spec
+++ b/python-nox.spec
@@ -1,57 +1,356 @@
-Name: python-nox
-Version: 2023.4.22
-Release: 1
-Summary: Flexible test automation
+%global _empty_manifest_terminate_build 0
+Name: python-nox
+Version: 2023.4.22
+Release: 1
+Summary: Flexible test automation.
+License: Apache-2.0
+URL: https://pypi.org/project/nox/
+Source0: https://mirrors.aliyun.com/pypi/web/packages/e7/3b/529fa8920b18b92085ed5923caee4aee112c65a7af99b34bd5a868b82e3e/nox-2023.4.22.tar.gz
+BuildArch: noarch
-License: Apache-2.0
-URL: https://github.com/wntrblm/nox
-Source0: %{url}/archive/v%{version}/nox-%{version}.tar.gz
-BuildArch: noarch
+Requires: (python3-argcomplete<4.0 with python3-argcomplete>=1.9.4)
+Requires: (python3-colorlog<7.0.0 with python3-colorlog>=2.6.1)
+Requires: (python3-importlib-metadata)
+Requires: (python3-packaging>=20.9)
+Requires: (python3-typing-extensions>=3.7.4)
+Requires: (python3-virtualenv>=14)
+Requires: (python3-jinja2)
+Requires: (python3-tox<4)
%description
-Nox is a command-line tool that automates testing in multiple Python
-environments, similar to tox. Unlike tox, Nox uses a standard Python
-file for configuration.
+<p align="center">
+<img src="https://github.com/wntrblm/nox/raw/main/docs/_static/alice.png" alt="logo" width=50%>
+</p>
+
+# Nox
+
+[![License](https://img.shields.io/github/license/wntrblm/nox)](https://github.com/wntrblm/nox)
+[![PyPI](https://img.shields.io/pypi/v/nox.svg?logo=python)](https://pypi.python.org/pypi/nox)
+[![GitHub](https://img.shields.io/github/v/release/wntrblm/nox?logo=github&sort=semver)](https://github.com/wntrblm/nox)
+[![Code Style](https://img.shields.io/badge/code%20style-black-black)](https://github.com/wntrblm/nox)
+[![CI](https://github.com/wntrblm/nox/workflows/CI/badge.svg)](https://github.com/wntrblm/nox/actions?query=workflow%3ACI)
+[![Downloads](https://static.pepy.tech/personalized-badge/nox?period=total&units=international_system&left_color=grey&right_color=green&left_text=Downloads)](https://pepy.tech/project/nox)
+
+*Flexible test automation with Python*
+
+* **Documentation:** [https://nox.readthedocs.io](https://nox.readthedocs.io)
+
+* **Source Code:** [https://github.com/wntrblm/nox](https://github.com/wntrblm/nox)
+
+## Overview
+
+`nox` is a command-line tool that automates testing in multiple Python environments, similar to [tox]. Unlike tox, Nox uses a standard Python file for configuration:
+
+```python
+import nox
+
+
+@nox.session
+def tests(session: nox.Session) -> None:
+ session.install("pytest")
+ session.run("pytest")
+
+@nox.session
+def lint(session: nox.Session) -> None:
+ session.install("flake8")
+ session.run("flake8", "--import-order-style", "google")
+```
+
+## Installation
+
+Nox is designed to be installed globally (not in a project virtual environment), the recommended way of doing this is via [pipx], a tool designed to install python CLI programs whilst keeping them separate from your global or system python.
+
+To install Nox with [pipx]:
+
+```shell
+pipx install nox
+```
+
+You can also use [pip] in your global python:
+
+```shell
+python3 -m pip install nox
+```
+
+You may want to user the [user-site] to avoid messing with your Global python install:
+
+```shell
+python3 -m pip install --user nox
+```
+
+## Usage
+
+### List all sessions
+
+```shell
+nox -l/--list
+```
+
+### Run all sessions
+
+```shell
+nox
+```
+
+### Run a particular session
+
+```shell
+nox -s/--session test
+```
+
+Checkout the [docs](https://nox.readthedocs.io) for more! 🎉
+
+## Contributing
+
+Nox is an open source project and welcomes contributions of all kinds, checkout the [contributing guide](CONTRIBUTING.md) for help on how to help us out!
+
+All contributors must follow the [code of conduct](CODE_OF_CONDUCT.md) and be nice to one another! 😃
+
+[tox]: https://tox.readthedocs.io
+[pipx]: https://pypa.github.io/pipx/
+[pip]: https://pip.pypa.io/en/stable/
+[user-site]: https://packaging.python.org/en/latest/tutorials/installing-packages/#installing-to-the-user-site
+
%package -n python3-nox
-Summary: Flexible test automation
+Summary: Flexible test automation.
Provides: python-nox
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-nox
+<p align="center">
+<img src="https://github.com/wntrblm/nox/raw/main/docs/_static/alice.png" alt="logo" width=50%>
+</p>
-BuildRequires: python3-devel
-BuildRequires: python3-setuptools
-BuildRequires: python3-setuptools_scm
-BuildRequires: python3-pip
-BuildRequires: python3-wheel
-BuildRequires: python3-hatchling
+# Nox
-%description -n python3-nox
-Nox is a command-line tool that automates testing in multiple Python
-environments, similar to tox. Unlike tox, Nox uses a standard Python
-file for configuration.
+[![License](https://img.shields.io/github/license/wntrblm/nox)](https://github.com/wntrblm/nox)
+[![PyPI](https://img.shields.io/pypi/v/nox.svg?logo=python)](https://pypi.python.org/pypi/nox)
+[![GitHub](https://img.shields.io/github/v/release/wntrblm/nox?logo=github&sort=semver)](https://github.com/wntrblm/nox)
+[![Code Style](https://img.shields.io/badge/code%20style-black-black)](https://github.com/wntrblm/nox)
+[![CI](https://github.com/wntrblm/nox/workflows/CI/badge.svg)](https://github.com/wntrblm/nox/actions?query=workflow%3ACI)
+[![Downloads](https://static.pepy.tech/personalized-badge/nox?period=total&units=international_system&left_color=grey&right_color=green&left_text=Downloads)](https://pepy.tech/project/nox)
-%prep
-%autosetup -n nox-%{version}
+*Flexible test automation with Python*
+
+* **Documentation:** [https://nox.readthedocs.io](https://nox.readthedocs.io)
+
+* **Source Code:** [https://github.com/wntrblm/nox](https://github.com/wntrblm/nox)
+
+## Overview
+
+`nox` is a command-line tool that automates testing in multiple Python environments, similar to [tox]. Unlike tox, Nox uses a standard Python file for configuration:
+
+```python
+import nox
+
+
+@nox.session
+def tests(session: nox.Session) -> None:
+ session.install("pytest")
+ session.run("pytest")
+
+@nox.session
+def lint(session: nox.Session) -> None:
+ session.install("flake8")
+ session.run("flake8", "--import-order-style", "google")
+```
+
+## Installation
+
+Nox is designed to be installed globally (not in a project virtual environment), the recommended way of doing this is via [pipx], a tool designed to install python CLI programs whilst keeping them separate from your global or system python.
+
+To install Nox with [pipx]:
+
+```shell
+pipx install nox
+```
+
+You can also use [pip] in your global python:
+
+```shell
+python3 -m pip install nox
+```
-# Use the newest tox 4
-sed -i 's/"tox<4"/"tox"/' pyproject.toml
+You may want to user the [user-site] to avoid messing with your Global python install:
-# Use current Python version instead of Python 2 in tests
-sed -i "s/2\.7/%python3_version/;s/27/%python3_version_nodots/" tests/test_tox_to_nox.py
+```shell
+python3 -m pip install --user nox
+```
+
+## Usage
+
+### List all sessions
+
+```shell
+nox -l/--list
+```
+
+### Run all sessions
+
+```shell
+nox
+```
+
+### Run a particular session
+
+```shell
+nox -s/--session test
+```
+
+Checkout the [docs](https://nox.readthedocs.io) for more! 🎉
+
+## Contributing
+
+Nox is an open source project and welcomes contributions of all kinds, checkout the [contributing guide](CONTRIBUTING.md) for help on how to help us out!
+
+All contributors must follow the [code of conduct](CODE_OF_CONDUCT.md) and be nice to one another! 😃
+
+[tox]: https://tox.readthedocs.io
+[pipx]: https://pypa.github.io/pipx/
+[pip]: https://pip.pypa.io/en/stable/
+[user-site]: https://packaging.python.org/en/latest/tutorials/installing-packages/#installing-to-the-user-site
+
+
+%package help
+Summary: Development documents and examples for nox
+Provides: python3-nox-doc
+%description help
+<p align="center">
+<img src="https://github.com/wntrblm/nox/raw/main/docs/_static/alice.png" alt="logo" width=50%>
+</p>
+
+# Nox
+
+[![License](https://img.shields.io/github/license/wntrblm/nox)](https://github.com/wntrblm/nox)
+[![PyPI](https://img.shields.io/pypi/v/nox.svg?logo=python)](https://pypi.python.org/pypi/nox)
+[![GitHub](https://img.shields.io/github/v/release/wntrblm/nox?logo=github&sort=semver)](https://github.com/wntrblm/nox)
+[![Code Style](https://img.shields.io/badge/code%20style-black-black)](https://github.com/wntrblm/nox)
+[![CI](https://github.com/wntrblm/nox/workflows/CI/badge.svg)](https://github.com/wntrblm/nox/actions?query=workflow%3ACI)
+[![Downloads](https://static.pepy.tech/personalized-badge/nox?period=total&units=international_system&left_color=grey&right_color=green&left_text=Downloads)](https://pepy.tech/project/nox)
+
+*Flexible test automation with Python*
+
+* **Documentation:** [https://nox.readthedocs.io](https://nox.readthedocs.io)
+
+* **Source Code:** [https://github.com/wntrblm/nox](https://github.com/wntrblm/nox)
+
+## Overview
+
+`nox` is a command-line tool that automates testing in multiple Python environments, similar to [tox]. Unlike tox, Nox uses a standard Python file for configuration:
+
+```python
+import nox
+
+
+@nox.session
+def tests(session: nox.Session) -> None:
+ session.install("pytest")
+ session.run("pytest")
+
+@nox.session
+def lint(session: nox.Session) -> None:
+ session.install("flake8")
+ session.run("flake8", "--import-order-style", "google")
+```
+
+## Installation
+
+Nox is designed to be installed globally (not in a project virtual environment), the recommended way of doing this is via [pipx], a tool designed to install python CLI programs whilst keeping them separate from your global or system python.
+
+To install Nox with [pipx]:
+
+```shell
+pipx install nox
+```
+
+You can also use [pip] in your global python:
+
+```shell
+python3 -m pip install nox
+```
+
+You may want to user the [user-site] to avoid messing with your Global python install:
+
+```shell
+python3 -m pip install --user nox
+```
+
+## Usage
+
+### List all sessions
+
+```shell
+nox -l/--list
+```
+
+### Run all sessions
+
+```shell
+nox
+```
+
+### Run a particular session
+
+```shell
+nox -s/--session test
+```
+
+Checkout the [docs](https://nox.readthedocs.io) for more! 🎉
+
+## Contributing
+
+Nox is an open source project and welcomes contributions of all kinds, checkout the [contributing guide](CONTRIBUTING.md) for help on how to help us out!
+
+All contributors must follow the [code of conduct](CODE_OF_CONDUCT.md) and be nice to one another! 😃
+
+[tox]: https://tox.readthedocs.io
+[pipx]: https://pypa.github.io/pipx/
+[pip]: https://pip.pypa.io/en/stable/
+[user-site]: https://packaging.python.org/en/latest/tutorials/installing-packages/#installing-to-the-user-site
+
+
+%prep
+%autosetup -n nox-2023.4.22
%build
-%pyproject_build
+%py3_build
%install
-%pyproject_install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-nox -f filelist.lst
+%dir %{python3_sitelib}/*
-%files -n python3-nox
-%license LICENSE
-%doc README.md
-%{_bindir}/nox
-%{_bindir}/tox-to-nox
-%{python3_sitelib}/nox-*.dist-info/
-%{python3_sitelib}/nox/
+%files help -f doclist.lst
+%{_docdir}/*
%changelog
-* Thu Aug 17 2023 mengzhaoa <mengzhaoa@isoftstone.com> - 2023.4.22-1
-- Init package python-nox of version 2023.4.22.
+* Tue Aug 22 2023 Python_Bot <Python_Bot@openeuler.org> - 2023.4.22-1
+- Package Spec generated