summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCoprDistGit <infra@openeuler.org>2023-09-08 06:13:18 +0000
committerCoprDistGit <infra@openeuler.org>2023-09-08 06:13:18 +0000
commit7804fd1c4a507cbb43be89d60b9d1b550268244e (patch)
tree40a22029b5f0e1db1aa657f5e90bed5bf29ea8e2
parentb24c234dc802742894969c061c8b97a70d83b166 (diff)
automatic import of python-pyupgradeopeneuler23.03
-rw-r--r--.gitignore1
-rw-r--r--python-pyupgrade.spec48
-rw-r--r--sources1
3 files changed, 50 insertions, 0 deletions
diff --git a/.gitignore b/.gitignore
index e69de29..eb35c05 100644
--- a/.gitignore
+++ b/.gitignore
@@ -0,0 +1 @@
+/pyupgrade-3.10.1.tar.gz
diff --git a/python-pyupgrade.spec b/python-pyupgrade.spec
new file mode 100644
index 0000000..3fb5fb9
--- /dev/null
+++ b/python-pyupgrade.spec
@@ -0,0 +1,48 @@
+%global _empty_manifest_terminate_build 0
+%global pypi_name pyupgrade
+
+%global _description %{expand:
+A tool (and pre-commit hook) to automatically upgrade syntax for newer versions of the language.}
+
+Name: python-%{pypi_name}
+Version: 3.10.1
+Release: 1
+Summary: A tool to automatically upgrade syntax for newer versions.
+License: MIT
+URL: https://github.com/asottile/pyupgrade
+Source0: %{url}/archive/%{version}/%{pypi_name}-%{version}.tar.gz
+BuildArch: noarch
+
+BuildRequires: python3-devel
+BuildRequires: python3-pip
+BuildRequires: python3-wheel
+BuildRequires: python3-setuptools
+BuildRequires: python3-setuptools_scm
+
+%description %_description
+
+%package -n python3-%{pypi_name}
+Summary: A tool to automatically upgrade syntax for newer versions.
+%{?python_provide:%python_provide python3-%{pypi_name}}
+
+%description -n python3-%{pypi_name} %_description
+
+%prep
+%autosetup -n %{pypi_name}-%{version}
+
+%build
+%py3_build
+
+%install
+%py3_install
+
+%files -n python3-%{pypi_name}
+%license LICENSE
+%doc README.md
+%{_bindir}/pyupgrade
+%{python3_sitelib}/%{pypi_name}/
+%{python3_sitelib}/%{pypi_name}-%{version}-*.egg-info/
+
+%changelog
+* Wed Aug 23 2023 li-miaomiao_zhr <mmlidc@isoftstone.com> - 3.10.1-1
+- Package init
diff --git a/sources b/sources
new file mode 100644
index 0000000..3100ca3
--- /dev/null
+++ b/sources
@@ -0,0 +1 @@
+7cc976f7e1abeb380d841b09aa55cec0 pyupgrade-3.10.1.tar.gz