summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCoprDistGit <infra@openeuler.org>2023-08-22 09:13:09 +0000
committerCoprDistGit <infra@openeuler.org>2023-08-22 09:13:09 +0000
commitf46773adc2949600768ded52556a1104a2f178da (patch)
tree7544cb88e371ec139e1e7e377ce930a1a7f48372
parentf347e430e6f749848ff429d79f840d5f95148af1 (diff)
automatic import of python-trioopeneuler23.03
-rw-r--r--python-trio.spec297
1 files changed, 229 insertions, 68 deletions
diff --git a/python-trio.spec b/python-trio.spec
index d01852a..50ddcab 100644
--- a/python-trio.spec
+++ b/python-trio.spec
@@ -1,67 +1,236 @@
%global _empty_manifest_terminate_build 0
-Name: python-trio
-Version: 0.22.2
-Release: 1
-Summary: A friendly Python library for async concurrency and I/O
-License: Apache-2.0
-URL: https://github.com/python-trio/trio
-Source0: https://files.pythonhosted.org/packages/04/b0/5ec370ef69832f3d6d79069af7097dcec0a8c68fa898822e49ad621c4af0/trio-0.22.2.tar.gz
-BuildArch: noarch
+Name: python-trio
+Version: 0.22.2
+Release: 1
+Summary: A friendly Python library for async concurrency and I/O
+License: MIT OR Apache-2.0
+URL: https://github.com/python-trio/trio
+Source0: https://mirrors.aliyun.com/pypi/web/packages/04/b0/5ec370ef69832f3d6d79069af7097dcec0a8c68fa898822e49ad621c4af0/trio-0.22.2.tar.gz
+BuildArch: noarch
+
+Requires: (python3-attrs(>=20.1.0))
+Requires: (python3-sortedcontainers)
+Requires: (python3-idna)
+Requires: (python3-outcome)
+Requires: (python3-sniffio)
+Requires: (python3-cffi(>=1.14))
+Requires: (python3-exceptiongroup(>=1.0.0rc9))
+
%description
-The Trio project's goal is to produce a production-quality, permissively licensed,
-async/await-native I/O library for Python. Like all async libraries,
-its main purpose is to help you write programs that do multiple things at the same time
-with parallelized I/O. A web spider that wants to fetch lots of pages in parallel,
-a web server that needs to juggle lots of downloads and websocket connections
-at the same time, a process supervisor monitoring multiple subprocesses...
-that sort of thing. Compared to other libraries, Trio attempts to distinguish
-itself with an obsessive focus on usability and correctness.
-Concurrency is complicated; we try to make it easy to get things right.
+.. image:: https://raw.githubusercontent.com/python-trio/trio/9b0bec646a31e0d0f67b8b6ecc6939726faf3e17/logo/logo-with-background.svg
+ :width: 200px
+ :align: right
+
+The Trio project's goal is to produce a production-quality, `permissively
+licensed <https://github.com/python-trio/trio/blob/master/LICENSE>`__,
+async/await-native I/O library for Python. Like all async libraries,
+its main purpose is to help you write programs that do **multiple
+things at the same time** with **parallelized I/O**. A web spider that
+wants to fetch lots of pages in parallel, a web server that needs to
+juggle lots of downloads and websocket connections at the same time, a
+process supervisor monitoring multiple subprocesses... that sort of
+thing. Compared to other libraries, Trio attempts to distinguish
+itself with an obsessive focus on **usability** and
+**correctness**. Concurrency is complicated; we try to make it *easy*
+to get things *right*.
+
+Trio was built from the ground up to take advantage of the `latest
+Python features <https://www.python.org/dev/peps/pep-0492/>`__, and
+draws inspiration from `many sources
+<https://github.com/python-trio/trio/wiki/Reading-list>`__, in
+particular Dave Beazley's `Curio <https://curio.readthedocs.io/>`__.
+The resulting design is radically simpler than older competitors like
+`asyncio <https://docs.python.org/3/library/asyncio.html>`__ and
+`Twisted <https://twistedmatrix.com/>`__, yet just as capable. Trio is
+the Python I/O library I always wanted; I find it makes building
+I/O-oriented programs easier, less error-prone, and just plain more
+fun. `Perhaps you'll find the same
+<https://github.com/python-trio/trio/wiki/Testimonials>`__.
+
+This project is young and still somewhat experimental: the overall
+design is solid and the existing features are fully tested and
+documented, but you may encounter missing functionality or rough
+edges. We *do* encourage you do use it, but you should `read and
+subscribe to issue #1
+<https://github.com/python-trio/trio/issues/1>`__ to get warning and a
+chance to give feedback about any compatibility-breaking changes.
+
+Vital statistics:
+
+* Supported environments: Linux, macOS, or Windows running some kind of Python
+ 3.7-or-better (either CPython or PyPy3 is fine). \*BSD and illumos likely
+ work too, but are not tested.
+
+* Install: ``python3 -m pip install -U trio`` (or on Windows, maybe
+ ``py -3 -m pip install -U trio``). No compiler needed.
+
+* Tutorial and reference manual: https://trio.readthedocs.io
+
+* Bug tracker and source code: https://github.com/python-trio/trio
+
+* Real-time chat: https://gitter.im/python-trio/general
+
+* Discussion forum: https://trio.discourse.group
+
+* License: MIT or Apache 2, your choice
+
+* Contributor guide: https://trio.readthedocs.io/en/latest/contributing.html
+
+* Code of conduct: Contributors are requested to follow our `code of
+ conduct
+ <https://trio.readthedocs.io/en/latest/code-of-conduct.html>`_
+ in all project spaces.
-%package -n python3-trio
-Summary: A friendly Python library for async concurrency and I/O
-Provides: python-trio
-# Base build requires
-BuildRequires: python3-devel
-BuildRequires: python3-setuptools
-BuildRequires: python3-pbr
-BuildRequires: python3-pip
-BuildRequires: python3-pip
-BuildRequires: python3-wheel
-BuildRequires: python3-hatchling
-# General requires
-BuildRequires: python3-attrs
-BuildRequires: python3-sortedcontainers
-BuildRequires: python3-idna
-BuildRequires: python3-cffi
+%package -n python3-trio
+Summary: A friendly Python library for async concurrency and I/O
+Provides: python-trio
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
%description -n python3-trio
-The Trio project's goal is to produce a production-quality, permissively licensed,
-async/await-native I/O library for Python.
+.. image:: https://raw.githubusercontent.com/python-trio/trio/9b0bec646a31e0d0f67b8b6ecc6939726faf3e17/logo/logo-with-background.svg
+ :width: 200px
+ :align: right
+
+The Trio project's goal is to produce a production-quality, `permissively
+licensed <https://github.com/python-trio/trio/blob/master/LICENSE>`__,
+async/await-native I/O library for Python. Like all async libraries,
+its main purpose is to help you write programs that do **multiple
+things at the same time** with **parallelized I/O**. A web spider that
+wants to fetch lots of pages in parallel, a web server that needs to
+juggle lots of downloads and websocket connections at the same time, a
+process supervisor monitoring multiple subprocesses... that sort of
+thing. Compared to other libraries, Trio attempts to distinguish
+itself with an obsessive focus on **usability** and
+**correctness**. Concurrency is complicated; we try to make it *easy*
+to get things *right*.
+
+Trio was built from the ground up to take advantage of the `latest
+Python features <https://www.python.org/dev/peps/pep-0492/>`__, and
+draws inspiration from `many sources
+<https://github.com/python-trio/trio/wiki/Reading-list>`__, in
+particular Dave Beazley's `Curio <https://curio.readthedocs.io/>`__.
+The resulting design is radically simpler than older competitors like
+`asyncio <https://docs.python.org/3/library/asyncio.html>`__ and
+`Twisted <https://twistedmatrix.com/>`__, yet just as capable. Trio is
+the Python I/O library I always wanted; I find it makes building
+I/O-oriented programs easier, less error-prone, and just plain more
+fun. `Perhaps you'll find the same
+<https://github.com/python-trio/trio/wiki/Testimonials>`__.
+
+This project is young and still somewhat experimental: the overall
+design is solid and the existing features are fully tested and
+documented, but you may encounter missing functionality or rough
+edges. We *do* encourage you do use it, but you should `read and
+subscribe to issue #1
+<https://github.com/python-trio/trio/issues/1>`__ to get warning and a
+chance to give feedback about any compatibility-breaking changes.
+
+Vital statistics:
+
+* Supported environments: Linux, macOS, or Windows running some kind of Python
+ 3.7-or-better (either CPython or PyPy3 is fine). \*BSD and illumos likely
+ work too, but are not tested.
+
+* Install: ``python3 -m pip install -U trio`` (or on Windows, maybe
+ ``py -3 -m pip install -U trio``). No compiler needed.
+
+* Tutorial and reference manual: https://trio.readthedocs.io
+
+* Bug tracker and source code: https://github.com/python-trio/trio
+
+* Real-time chat: https://gitter.im/python-trio/general
+
+* Discussion forum: https://trio.discourse.group
+
+* License: MIT or Apache 2, your choice
+
+* Contributor guide: https://trio.readthedocs.io/en/latest/contributing.html
+
+* Code of conduct: Contributors are requested to follow our `code of
+ conduct
+ <https://trio.readthedocs.io/en/latest/code-of-conduct.html>`_
+ in all project spaces.
+
%package help
-Summary: A friendly Python library for async concurrency and I/O
-Provides: python3-trio-doc
+Summary: Development documents and examples for trio
+Provides: python3-trio-doc
%description help
-The Trio project's goal is to produce a production-quality, permissively licensed,
-async/await-native I/O library for Python. Like all async libraries,
-its main purpose is to help you write programs that do multiple things at the same time
-with parallelized I/O. A web spider that wants to fetch lots of pages in parallel,
-a web server that needs to juggle lots of downloads and websocket connections
-at the same time, a process supervisor monitoring multiple subprocesses...
-that sort of thing. Compared to other libraries, Trio attempts to distinguish
-itself with an obsessive focus on usability and correctness.
-Concurrency is complicated; we try to make it easy to get things right.
+.. image:: https://raw.githubusercontent.com/python-trio/trio/9b0bec646a31e0d0f67b8b6ecc6939726faf3e17/logo/logo-with-background.svg
+ :width: 200px
+ :align: right
+
+The Trio project's goal is to produce a production-quality, `permissively
+licensed <https://github.com/python-trio/trio/blob/master/LICENSE>`__,
+async/await-native I/O library for Python. Like all async libraries,
+its main purpose is to help you write programs that do **multiple
+things at the same time** with **parallelized I/O**. A web spider that
+wants to fetch lots of pages in parallel, a web server that needs to
+juggle lots of downloads and websocket connections at the same time, a
+process supervisor monitoring multiple subprocesses... that sort of
+thing. Compared to other libraries, Trio attempts to distinguish
+itself with an obsessive focus on **usability** and
+**correctness**. Concurrency is complicated; we try to make it *easy*
+to get things *right*.
+
+Trio was built from the ground up to take advantage of the `latest
+Python features <https://www.python.org/dev/peps/pep-0492/>`__, and
+draws inspiration from `many sources
+<https://github.com/python-trio/trio/wiki/Reading-list>`__, in
+particular Dave Beazley's `Curio <https://curio.readthedocs.io/>`__.
+The resulting design is radically simpler than older competitors like
+`asyncio <https://docs.python.org/3/library/asyncio.html>`__ and
+`Twisted <https://twistedmatrix.com/>`__, yet just as capable. Trio is
+the Python I/O library I always wanted; I find it makes building
+I/O-oriented programs easier, less error-prone, and just plain more
+fun. `Perhaps you'll find the same
+<https://github.com/python-trio/trio/wiki/Testimonials>`__.
+
+This project is young and still somewhat experimental: the overall
+design is solid and the existing features are fully tested and
+documented, but you may encounter missing functionality or rough
+edges. We *do* encourage you do use it, but you should `read and
+subscribe to issue #1
+<https://github.com/python-trio/trio/issues/1>`__ to get warning and a
+chance to give feedback about any compatibility-breaking changes.
+
+Vital statistics:
+
+* Supported environments: Linux, macOS, or Windows running some kind of Python
+ 3.7-or-better (either CPython or PyPy3 is fine). \*BSD and illumos likely
+ work too, but are not tested.
+
+* Install: ``python3 -m pip install -U trio`` (or on Windows, maybe
+ ``py -3 -m pip install -U trio``). No compiler needed.
+
+* Tutorial and reference manual: https://trio.readthedocs.io
+
+* Bug tracker and source code: https://github.com/python-trio/trio
+
+* Real-time chat: https://gitter.im/python-trio/general
+
+* Discussion forum: https://trio.discourse.group
+
+* License: MIT or Apache 2, your choice
+
+* Contributor guide: https://trio.readthedocs.io/en/latest/contributing.html
+
+* Code of conduct: Contributors are requested to follow our `code of
+ conduct
+ <https://trio.readthedocs.io/en/latest/code-of-conduct.html>`_
+ in all project spaces.
+
%prep
-%autosetup -n trio-%{version}
+%autosetup -n trio-0.22.2
%build
-%pyproject_build
+%py3_build
%install
-%pyproject_install
-
+%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
@@ -69,39 +238,31 @@ if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
- find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+ find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
- find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+ find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
- find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+ find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
- find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+ find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
- find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+ find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
-%files -n python3-trio
-%license LICENSE LICENSE.APACHE2 LICENSE.MIT
-%doc README.rst
-%{python3_sitelib}/trio*
+%files -n python3-trio -f filelist.lst
+%dir %{python3_sitelib}/*
-%files help
+%files help -f doclist.lst
%{_docdir}/*
%changelog
-* Tue Aug 22 2023 luolu12 <luluoc@isoftstone.com> - 0.22.2-1
-- Upgrade package python3-trio of version 0.22.2
-
-* Fri Jun 30 2023 luolu12 <luluoc@isoftstone.com> - 0.22.0-1
-- Upgrade package python3-trio of version 0.22.0
-
-* Thu Jul 21 2022 renliang16 <renliang@uniontech.com> - 0.14.0-1
-- Init package python3-trio of version 0.14.0
+* Tue Aug 22 2023 Python_Bot <Python_Bot@openeuler.org> - 0.22.2-1
+- Package Spec generated