summaryrefslogtreecommitdiff
path: root/cobbler-nocov.patch
diff options
context:
space:
mode:
authorCoprDistGit <infra@openeuler.org>2025-04-11 06:18:57 +0000
committerCoprDistGit <infra@openeuler.org>2025-04-11 06:18:57 +0000
commitff0827b72e6d4046af41c35eeb25a6ac7216feb7 (patch)
tree924ca3e18b7a334a992bd44959f5129f221634f8 /cobbler-nocov.patch
parent2f8d928a90ba84e9d782a9d2a9a8cc904fdee7c3 (diff)
Diffstat (limited to 'cobbler-nocov.patch')
-rw-r--r--cobbler-nocov.patch41
1 files changed, 41 insertions, 0 deletions
diff --git a/cobbler-nocov.patch b/cobbler-nocov.patch
new file mode 100644
index 0000000..c50edfd
--- /dev/null
+++ b/cobbler-nocov.patch
@@ -0,0 +1,41 @@
+diff --git a/setup.py b/setup.py
+index 59f7601..023d84b 100644
+--- a/setup.py
++++ b/setup.py
+@@ -341,17 +341,9 @@ class test_command(Command):
+
+ def run(self):
+ import pytest
+- from coverage import Coverage
+-
+- cov = Coverage()
+- cov.erase()
+- cov.start()
+
+ result = pytest.main()
+
+- cov.stop()
+- cov.save()
+- cov.html_report(directory="covhtml")
+ sys.exit(int(bool(len(result.failures) > 0 or len(result.errors) > 0)))
+
+
+@@ -479,7 +471,6 @@ if __name__ == "__main__":
+ },
+ license="GPLv2+",
+ setup_requires=[
+- "coverage",
+ "distro",
+ "setuptools",
+ "sphinx",
+@@ -501,10 +492,7 @@ if __name__ == "__main__":
+ "lint": ["pyflakes", "pycodestyle", "pylint", "black", "mypy"],
+ "test": [
+ "pytest>6",
+- "pytest-cov",
+- "codecov",
+ "pytest-mock",
+- "pytest-benchmark",
+ ],
+ "docs": ["sphinx", "sphinx-rtd-theme", "sphinxcontrib-apidoc"],
+ # We require the current version to properly detect duplicate issues