summaryrefslogtreecommitdiff
path: root/perl-Net-INET6Glue.spec
diff options
context:
space:
mode:
Diffstat (limited to 'perl-Net-INET6Glue.spec')
-rw-r--r--perl-Net-INET6Glue.spec75
1 files changed, 75 insertions, 0 deletions
diff --git a/perl-Net-INET6Glue.spec b/perl-Net-INET6Glue.spec
new file mode 100644
index 0000000..cde0dcc
--- /dev/null
+++ b/perl-Net-INET6Glue.spec
@@ -0,0 +1,75 @@
+%global _empty_manifest_terminate_build 0
+Name: perl-Net-INET6Glue
+Version: 0.604
+Release: 1
+Summary: Make common modules IPv6 ready by hotpatching
+License: GPL-1.0-only or Artistic-1.0-Perl
+Group: Development/Libraries
+URL: http://search.cpan.org/dist/Net-INET6Glue/
+Source0: http://www.cpan.org/authors/id/S/SU/SULLR/Net-INET6Glue-%{version}.tar.gz
+BuildArch: noarch
+BuildRequires: perl-generators
+BuildRequires: perl(ExtUtils::MakeMaker)
+BuildRequires: perl(IO::Socket::IP) >= 0.25
+BuildRequires: perl(Net::FTP) >= 2.75
+Requires: perl(IO::Socket::IP) >= 0.25
+Requires: perl(Net::FTP) >= 2.75
+%description
+Net::INET6Glue is a collection of modules to make common modules IPv6 ready
+by hotpatching them.
+%package help
+Summary : Make common modules IPv6 ready by hotpatching
+Provides: perl-Net-INET6Glue-doc
+%description help
+Net::INET6Glue is a collection of modules to make common modules IPv6 ready
+by hotpatching them.
+%prep
+%setup -q -n Net-INET6Glue-%{version}
+%build
+export PERL_MM_OPT=""
+%{__perl} Makefile.PL INSTALLDIRS=vendor
+make %{?_smp_mflags}
+
+%install
+export PERL_MM_OPT=""
+rm -rf $RPM_BUILD_ROOT
+
+make pure_install PERL_INSTALL_ROOT=$RPM_BUILD_ROOT
+
+find $RPM_BUILD_ROOT -type f -name .packlist -exec rm -f {} \;
+find $RPM_BUILD_ROOT -depth -type d -exec rmdir {} 2>/dev/null \;
+
+%{_fixperms} $RPM_BUILD_ROOT/*
+
+pushd %{buildroot}
+touch filelist.lst
+if [ -d usr/bin ];then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ];then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ];then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib ];then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+%check || :
+make test
+
+%clean
+rm -rf $RPM_BUILD_ROOT
+
+%files -f filelist.lst
+%defattr(-,root,root,-)
+%doc Changes COPYRIGHT META.json README
+%{perl_vendorlib}/*
+%files help
+%{_mandir}/*
+
+%changelog
+* Sun May 23 2021 Perl_Bot <Perl_Bot@openeuler.org> 0.604-1
+- Specfile autogenerated by Perl_Bot