summaryrefslogtreecommitdiff
path: root/pytorch.spec
diff options
context:
space:
mode:
Diffstat (limited to 'pytorch.spec')
-rw-r--r--pytorch.spec3
1 files changed, 2 insertions, 1 deletions
diff --git a/pytorch.spec b/pytorch.spec
index 73c7523..85ea312 100644
--- a/pytorch.spec
+++ b/pytorch.spec
@@ -27,7 +27,7 @@ BuildRequires: python3-setuptools_scm
BuildRequires: python3-pbr
BuildRequires: python3-pip
BuildRequires: python3-wheel
-BuildRequires: python3-hatchling
+# BuildRequires: python3-hatchling
BuildRequires: python3-astunparse
BuildRequires: python3-numpy
@@ -55,6 +55,7 @@ You can reuse your favorite Python packages such as NumPy, SciPy and Cython to e
%autosetup -p1 -n %{name}-v%{version}
%build
+pip install hatchling
export CFLAGS+=" -Wno-error=maybe-uninitialized -Wno-error=uninitialized -Wno-error=restrict -fPIC"
export CXXFLAGS+=" -Wno-error=maybe-uninitialized -Wno-error=uninitialized -Wno-error=restrict -fPIC"
%pyproject_build