summaryrefslogtreecommitdiff
path: root/pytorchvideo.spec
diff options
context:
space:
mode:
Diffstat (limited to 'pytorchvideo.spec')
-rw-r--r--pytorchvideo.spec76
1 files changed, 45 insertions, 31 deletions
diff --git a/pytorchvideo.spec b/pytorchvideo.spec
index 9778c41..43d7ccb 100644
--- a/pytorchvideo.spec
+++ b/pytorchvideo.spec
@@ -1,55 +1,69 @@
%global _empty_manifest_terminate_build 0
%global _unpackaged_files_terminate_build 0
-Name: pytorchvideo
-Version: 0.1.3
-Release: 1%{?dist}
-Summary: %{name} is a torch ecosystem tools
-License: MIT
-URL: https://pytorchvideo.org
-Source0: https://github.com/facebookresearch/%{name}/archive/refs/tags/%{version}.tar.gz
+# using global macro to speed up the spec editing
+%global pkg_name pytorchvideo
+%global version 0.1.3
+%global pkg_summary %{name} is a torch ecosystem tools
+%global pkg_desc %{expand:%{pkg_summary}}
+%global open_license MIT
-%description
-A deep learning library for video understanding research.
+Name: %{pkg_name}
+Version: %{version}
+Release: 1
+Summary: %{pkg_summary}
+License: %{open_license}
+
+# the url and source0 url here
+URL: https://pytorchvideo.org
+Source0: https://github.com/facebookresearch/%{pkg_name}/archive/refs/tags/%{version}.tar.gz#/%{pkg_name}-%{version}.tar.gz
-# pkg section 1
-%package -n python3-pytorchvideo
-Summary: A deep learning library for video understanding research.
-Provides: python-pytorchvideo
+# build requires
BuildRequires: python3-devel
BuildRequires: python3-setuptools
-BuildRequires: python3-setuptools_scm
-BuildRequires: python3-rpm-macros
BuildRequires: python3-pip
BuildRequires: python3-wheel
-BuildRequires: python3-hatchling
+BuildRequires: python3-hatchling
+BuildRequires: python3-setuptools_scm
-# use the auto build requires
-%?python_enable_dependency_generator
+# higharchy desc
+%description
+%{pkg_summary}
+
+# sub pkg section 1
+%package -n python3-%{pkg_name}
+Summary: %{pkg_summary}
-%description -n python3-pytorchvideo
-A deep learning library for video understanding research.
+%description -n python3-%{pkg_name}
+%{pkg_desc}
-%package help
-Summary: docs for the pytorchvideo
-Provides: python3-pytorchvideo-doc
-%description help
-description for the doc of the python3-pytorchvideo's usage
+# pkg section: help optional
+# %package -n help
+# Summary: docs for the transformers
+# Provides: python3-transformers-doc
+# %description -n help
+# description for the doc of the python3-transformers
+# the name here should match the name of the dir of the source code zip
+# which got from the .tar.gz unzipped
%prep
-%autosetup -p1 -n %{name}-%{version}
+%autosetup -p1 -n %{pkg_name}-%{version}
+# using python poject build, supplied by setup.py or pyproject.toml
%build
%pyproject_build
+# using python project install, supplied by setup.py or pyproject.toml
%install
%pyproject_install
-%files -n python3-%{name}
+# point out the files here
+%files -n python3-%{pkg_name}
%doc *.md
-%license LICENSE
-%{python3_sitelib}/%{name}/
+%license LICENSE*
+%{python3_sitelib}/%{pkg_name}/*
+
%changelog
-* Fri Jan 26 2024 menma <1316818279@qq.com> - 1.6.3-1
-- Package init
+* Mon Apr 15 2024 youser<1328699220@qq.com>
+- pkg init