summaryrefslogtreecommitdiff
path: root/bat.spec
diff options
context:
space:
mode:
Diffstat (limited to 'bat.spec')
-rw-r--r--bat.spec39
1 files changed, 39 insertions, 0 deletions
diff --git a/bat.spec b/bat.spec
new file mode 100644
index 0000000..f0d5211
--- /dev/null
+++ b/bat.spec
@@ -0,0 +1,39 @@
+%global debug_package %{nil}
+
+Name: bat
+Version: 0.23.0
+Release: 1
+Summary: A cat(1) clone with syntax highlighting and Git integration.
+License: Apache-2.0 and MIT
+URL: https://github.com/sharkdp/bat
+
+Source0: https://gitee.com/src-openeuler/bat/blob/master/bat-%{version}.tar.gz
+Source1: config
+
+BuildRequires: cargo git
+
+%description
+A cat(1) clone with syntax highlighting and Git integration.
+
+%prep
+%autosetup -n %{name}-%{version}
+cargo -V
+mkdir -p ~/.cargo/
+cp %{SOURCE1} ~/.cargo/
+
+%build
+cargo build --release
+
+%install
+mkdir -p %{buildroot}%{_bindir}
+cp ./target/release/bat %{buildroot}%{_bindir}
+
+%files
+%defattr(-,root,root)
+%{_bindir}/%{name}
+%doc README.md
+%license LICENSE-MIT LICENSE-APACHE
+
+%changelog
+* Thu Jul 06 2023 zerocraft <zero.craft@hotmail.com> - 0.23.0-1
+- openEuler init