summaryrefslogtreecommitdiff
path: root/libpq.spec
diff options
context:
space:
mode:
authorCoprDistGit <infra@openeuler.org>2023-08-30 03:53:08 +0000
committerCoprDistGit <infra@openeuler.org>2023-08-30 03:53:08 +0000
commit3c2f84074260b0b78e73898e0d4476a6c604a23d (patch)
treebe28dd9c6c5ed029bc41cc6e00538df7ded43e8c /libpq.spec
parent9e5343f26011eb32e35a9c3a30f4766d4ba5115f (diff)
automatic import of libpq
Diffstat (limited to 'libpq.spec')
-rw-r--r--libpq.spec80
1 files changed, 80 insertions, 0 deletions
diff --git a/libpq.spec b/libpq.spec
new file mode 100644
index 0000000..f11eba5
--- /dev/null
+++ b/libpq.spec
@@ -0,0 +1,80 @@
+Name: libpq
+Version: 11.21
+Release: 1
+Summary: A share library of PostgreSQL
+License: PostgreSQL
+Url: http://www.postgresql.org/
+Source0: https://ftp.postgresql.org/pub/source/v11.21/postgresql-11.21.tar.bz2
+BuildRequires: gcc glibc-devel bison flex gawk zlib-devel openssl-devel
+BuildRequires: krb5-devel openldap-devel gettext multilib-rpm-config
+Obsoletes: postgresql-libs < 11
+Provides: postgresql-libs = %{version}-%{release}
+%description
+PostgreSQL is a powerful, open source object-relational database system
+that uses and extends the SQL language combined with many features that
+safely store and scale the most complicated data workloads. This package
+provides the essential shared library for any PostgreSQL client program
+or interface.
+
+%package devel
+Summary: Development files for building PostgreSQL client tools
+Requires: libpq%{?_isa} = %{version}-%{release}
+Provides: postgresql-devel = %{version}-%{release}
+Obsoletes: postgresql-devel < 11
+%description devel
+The development package of libpq
+%prep
+%autosetup -n postgresql-%{version} -p1
+
+%build
+export SYMBOL_VERSION_PREFIX=RHPG_
+%configure --disable-rpath --with-ldap --with-openssl --with-gssapi \
+ --enable-nls --without-readline --datadir=%_datadir/pgsql
+%global build_subdirs \\\
+ src/interfaces/libpq \\\
+ src/bin/pg_config \\\
+ src/include
+for subdir in %build_subdirs; do
+ %make_build -C "$subdir"
+done
+
+%install
+for subdir in %build_subdirs; do
+ %make_install -C "$subdir"
+done
+find $RPM_BUILD_ROOT -name '*.a' -delete
+rm -r $RPM_BUILD_ROOT%_includedir/pgsql/server
+%multilib_fix_c_header --file "%_includedir/pg_config.h"
+%multilib_fix_c_header --file "%_includedir/pg_config_ext.h"
+
+cp /dev/null libpq.lst
+%find_lang libpq5-11
+cat libpq5-11.lang >>libpq.lst
+cp /dev/null libpq-devel.lst
+%find_lang pg_config-11
+cat pg_config-11.lang >>libpq-devel.lst
+
+%files -f libpq.lst
+%license COPYRIGHT
+%_libdir/libpq.so.5*
+%dir %_datadir/pgsql
+%doc %_datadir/pgsql/pg_service.conf.sample
+
+%files devel -f libpq-devel.lst
+%_bindir/pg_config
+%_includedir/*
+%_libdir/libpq.so
+%_libdir/pkgconfig/libpq.pc
+
+%changelog
+* Wed Aug 20 2023 ZhenyuZheng <zhengzhenyu@openeuler.sh> - 11.21-1
+- Bump to 11.21 for CVE-2023-39417
+
+* Wed Sep 2 2020 chengzihan <chengzihan2@huawei.com> - 11.2-5
+- Change actually numbers of version and release to macros
+
+* Wed Aug 26 2020 chengzihan <chengzihan2@huawei.com> - 11.2-4
+- Fix installing problem of libpq-devel
+
+* Tue Nov 26 2019 openEuler Buildteam <buildteam@openeuler.org> - 11.2-3
+- Package init