summaryrefslogtreecommitdiff
path: root/awscli.spec
diff options
context:
space:
mode:
authorCoprDistGit <infra@openeuler.org>2023-07-24 15:41:16 +0000
committerCoprDistGit <infra@openeuler.org>2023-07-24 15:41:16 +0000
commit31fe495622312559f0550c21dee94ecf7e63d835 (patch)
tree376dfbc554b5affbc9ac00814a2b5398f5efba03 /awscli.spec
parent371020df349e9eb65ace8017b441416a1bf4b7a7 (diff)
automatic import of python-awscliopeneuler23.03
Diffstat (limited to 'awscli.spec')
-rw-r--r--awscli.spec84
1 files changed, 84 insertions, 0 deletions
diff --git a/awscli.spec b/awscli.spec
new file mode 100644
index 0000000..94bee89
--- /dev/null
+++ b/awscli.spec
@@ -0,0 +1,84 @@
+%global _empty_manifest_terminate_build 0
+%global __requires_exclude ^python3\\.1?[0-9]dist\\((botocore|colorama|docutils|pyyaml|rsa|s3transfer)\\)
+%undefine __pythondist_provides
+%undefine __pythonname_provides
+
+Name: python-awscli
+Version: 1.29.9
+Release: 1
+Summary: Universal Command Line Environment for AWS.
+License: Apache License 2.0
+URL: http://aws.amazon.com/cli/
+Source0: https://files.pythonhosted.org/packages/1a/27/7b86afe099b4c7d4685067dc565da10f00e4e2e5ab2b7e07d8b727f07548/aws-cli-1.29.9.tar.gz
+BuildArch: noarch
+
+Requires: python3-botocore
+Requires: python3-docutils
+Requires: python3-s3transfer
+Requires: python3-PyYAML
+Requires: python3-colorama
+Requires: python3-rsa
+
+%description
+This package provides a unified command line interface to Amazon Web
+Services.
+
+%package -n python3-awscli
+Summary: Universal Command Line Environment for AWS.
+Provides: python-awscli
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+%description -n python3-awscli
+This package provides a unified command line interface to Amazon Web
+Services.
+
+%package help
+Summary: Development documents and examples for awscli
+Provides: python3-awscli-doc
+%description help
+This package provides a unified command line interface to Amazon Web
+Services.
+
+%prep
+%autosetup -n aws-cli-1.29.9
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-awscli -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Mon Jul 24 2023 Zheng Zhenyu <zhengzhenyu@openeuler.sh> - 1.29.9-1
+- Add initial spec for 1.29.9