summaryrefslogtreecommitdiff
path: root/libfilezilla.spec
diff options
context:
space:
mode:
Diffstat (limited to 'libfilezilla.spec')
-rw-r--r--libfilezilla.spec58
1 files changed, 58 insertions, 0 deletions
diff --git a/libfilezilla.spec b/libfilezilla.spec
new file mode 100644
index 0000000..375d700
--- /dev/null
+++ b/libfilezilla.spec
@@ -0,0 +1,58 @@
+Name: libfilezilla
+Version: 0.47.0
+Release: 1%{?dist}
+URL: https://lib.filezilla-project.org/
+Summary: C++ Library for FileZilla
+License: GPL-2.0-or-later
+
+Source0: https://download.filezilla-project.org/%{name}/%{name}-%{version}.tar.xz
+
+BuildRequires: gcc-c++
+BuildRequires: gettext
+BuildRequires: gnutls-devel
+BuildRequires: nettle-devel
+BuildRequires: make
+
+%description
+libfilezilla is a small and modern C++ library, offering some basic
+functionality to build high-performing, platform-independent programs.
+
+%package devel
+Summary: Development files for C++ Library for FileZilla
+Requires: %{name}%{?_isa} = %{version}-%{release}
+
+%description devel
+libfilezilla is a small and modern C++ library, offering some basic
+functionality to build high-performing, platform-independent programs.
+
+This package contains files needed to compile code using libfilezilla.
+
+%prep
+%autosetup -p1
+
+%build
+%configure --disable-static
+%make_build
+
+%install
+%make_install
+
+%ldconfig_scriptlets
+
+%find_lang %{name}
+
+%files -f %{name}.lang
+%license COPYING
+%doc AUTHORS ChangeLog NEWS README
+%{_libdir}/libfilezilla.so.43*
+
+%files devel
+%doc doc/*
+%{_includedir}/*
+%{_libdir}/libfilezilla.so
+%{_libdir}/libfilezilla.la
+%{_libdir}/pkgconfig/libfilezilla.pc
+
+%changelog
+* Mon May 27 2024 binshuo <binshuozu@gmail.com> - 1.14-1
+- Initial Release