summaryrefslogtreecommitdiff
path: root/python-pyro-ppl.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-pyro-ppl.spec')
-rw-r--r--python-pyro-ppl.spec84
1 files changed, 84 insertions, 0 deletions
diff --git a/python-pyro-ppl.spec b/python-pyro-ppl.spec
new file mode 100644
index 0000000..dfb33f7
--- /dev/null
+++ b/python-pyro-ppl.spec
@@ -0,0 +1,84 @@
+%global _empty_manifest_terminate_build 0
+
+Name: python-pyro-ppl
+Version: 1.8.6
+Release: 1
+Summary: Deep universal probabilistic programming with Python and PyTorch
+License: Apache-2.0
+URL: https://github.com/pyro-ppl/pyro
+Source0: https://github.com/pyro-ppl/pyro/archive/refs/tags/%{version}.tar.gz#/%{name}-%{version}.tar.gz
+
+Requires: python3-numpy
+Requires: python3-opt-einsum
+Requires: python3-pytorch
+Requires: python3-tqdm
+
+%description
+Pyro is a flexible, scalable deep probabilistic programming library built on PyTorch. Notably, it was designed with these principles in mind:
+- Universal: Pyro is a universal PPL - it can represent any computable probability distribution.
+- Scalable: Pyro scales to large data sets with little overhead compared to hand-written code.
+- Minimal: Pyro is agile and maintainable. It is implemented with a small core of powerful, composable abstractions.
+- Flexible: Pyro aims for automation when you want it, control when you need it. This is accomplished through high-level
+ abstractions to express generative and inference models, while allowing experts easy-access to customize inference.
+
+%package -n python3-pyro-ppl
+Summary: Deep universal probabilistic programming with Python and PyTorch
+Provides: python-pyro-ppl
+
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-setuptools_scm
+BuildRequires: python3-pbr
+BuildRequires: python3-pip
+BuildRequires: python3-wheel
+
+%description -n python3-pyro-ppl
+Pyro is a flexible, scalable deep probabilistic programming library built on PyTorch. Notably, it was designed with these principles in mind:
+- Universal: Pyro is a universal PPL - it can represent any computable probability distribution.
+- Scalable: Pyro scales to large data sets with little overhead compared to hand-written code.
+- Minimal: Pyro is agile and maintainable. It is implemented with a small core of powerful, composable abstractions.
+- Flexible: Pyro aims for automation when you want it, control when you need it. This is accomplished through high-level
+ abstractions to express generative and inference models, while allowing experts easy-access to customize inference.
+
+%package help
+Summary: Development documents and examples for python-pyro-ppl
+Provides: python3-pyro-ppl-doc
+
+%description help
+Pyro is a flexible, scalable deep probabilistic programming library built on PyTorch. Notably, it was designed with these principles in mind:
+- Universal: Pyro is a universal PPL - it can represent any computable probability distribution.
+- Scalable: Pyro scales to large data sets with little overhead compared to hand-written code.
+- Minimal: Pyro is agile and maintainable. It is implemented with a small core of powerful, composable abstractions.
+- Flexible: Pyro aims for automation when you want it, control when you need it. This is accomplished through high-level
+ abstractions to express generative and inference models, while allowing experts easy-access to customize inference.
+
+%prep
+%autosetup -p1 -n pyro-%{version}
+
+%build
+%pyproject_build
+
+%install
+%pyproject_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-pyro-ppl
+%doc *.md
+%license LICENSE.md
+%{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Sun Jan 28 2024 Binshuo Zu <274620705z@gmail.com> - 1.8.6-1
+- Package init