summaryrefslogtreecommitdiff
path: root/torchtext.spec
diff options
context:
space:
mode:
Diffstat (limited to 'torchtext.spec')
-rw-r--r--torchtext.spec94
1 files changed, 94 insertions, 0 deletions
diff --git a/torchtext.spec b/torchtext.spec
new file mode 100644
index 0000000..0be24e1
--- /dev/null
+++ b/torchtext.spec
@@ -0,0 +1,94 @@
+%global _empty_manifest_terminate_build 0
+Name: torchtext
+Version: 0.16.2
+Release: 1
+Summary: Models, data loaders and abstractions for language processing, powered by PyTorch
+License: BSD-3-Clause
+URL: https://pytorch.org/text/
+Source0: https://github.com/pytorch/text/archive/refs/tags/v%{version}.zip
+
+Source1: double-conversion.zip
+Source2: re2.zip
+Source3: sentencepiece.zip
+Source4: utf8proc.zip
+
+Patch0: 0001-manunally-add-submodule.patch
+BuildRequires: g++
+Requires: python3-numpy
+Requires: python3-pytorch
+Requires: python3-requests
+Requires: python3-tqdm
+
+%description
+This repository consists of: The raw text iterators for common NLP datasets. Some basic NLP building blocks
+Basic text-processing transformations. Pre-trained models, Vocab and Vectors related classes and factory functions
+Example NLP workflows with PyTorch and torchtext library.
+
+%package -n python3-torchtext
+Summary: Models, data loaders and abstractions for language processing, powered by PyTorch
+Provides: python-torchtext
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-setuptools_scm
+BuildRequires: python3-pbr
+BuildRequires: python3-pip
+BuildRequires: python3-wheel
+BuildRequires: python3-hatchling
+
+BuildRequires: python3-sympy
+BuildRequires: ninja-build
+BuildRequires: numactl
+BuildRequires: cmake
+
+%description -n python3-torchtext
+This repository consists of: The raw text iterators for common NLP datasets. Some basic NLP building blocks
+Basic text-processing transformations. Pre-trained models, Vocab and Vectors related classes and factory functions
+Example NLP workflows with PyTorch and torchtext library.
+
+%package help
+Summary: Development documents and examples for torchtext
+Provides: python3-torchtext-doc
+%description help
+This repository consists of: The raw text iterators for common NLP datasets. Some basic NLP building blocks
+Basic text-processing transformations. Pre-trained models, Vocab and Vectors related classes and factory functions
+Example NLP workflows with PyTorch and torchtext library.
+
+
+%prep
+unzip -q %{SOURCE1}
+unzip -q %{SOURCE2}
+unzip -q %{SOURCE3}
+unzip -q %{SOURCE4}
+%autosetup -p1 -n text-%{version}
+mv ../double-conversion ./third_party/
+mv ../re2 ./third_party/
+mv ../sentencepiece ./third_party/
+mv ../utf8proc ./third_party/
+
+%build
+%pyproject_build
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/doclist.lst .
+
+%install
+%pyproject_install
+
+%files -n python3-torchtext
+%doc *.md
+%license LICENSE
+%{python3_sitearch}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Sun Jan 28 2024 Binshuo Zu <274620705z@gmail.com> - 0.16.2-1
+- Package init