summaryrefslogtreecommitdiff
path: root/codec2.spec
diff options
context:
space:
mode:
authorCoprDistGit <infra@openeuler.org>2025-01-19 09:14:40 +0000
committerCoprDistGit <infra@openeuler.org>2025-01-19 09:14:40 +0000
commitea6037b143c4b60ff28c0419e13fd4389ce20e4c (patch)
tree4c010afc49ef9f2d7b5ba053d7789e40cbebcb35 /codec2.spec
parent682a8b0bbd9e98605305704220a3488256578bba (diff)
automatic import of codec2openeuler24.09
Diffstat (limited to 'codec2.spec')
-rw-r--r--codec2.spec10
1 files changed, 6 insertions, 4 deletions
diff --git a/codec2.spec b/codec2.spec
index 50645f9..6392c71 100644
--- a/codec2.spec
+++ b/codec2.spec
@@ -46,14 +46,16 @@ Example code for Codec 2
%build
-%cmake -DCMAKE_BUILD_TYPE=RelWithDebInfo \
- -DLPCNET=ON
+cmake -DCMAKE_BUILD_TYPE=RelWithDebInfo \
+ -DLPCNET=ON \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -B build
-%cmake_build
+cmake --build build
%install
-%cmake_install
+DESTDIR="%{buildroot}" cmake --install build
# Create and install pkgconfig file
mkdir -p %{buildroot}%{_libdir}/pkgconfig