summaryrefslogtreecommitdiff
path: root/codec2.spec
diff options
context:
space:
mode:
Diffstat (limited to 'codec2.spec')
-rw-r--r--codec2.spec10
1 files changed, 6 insertions, 4 deletions
diff --git a/codec2.spec b/codec2.spec
index 50645f9..6392c71 100644
--- a/codec2.spec
+++ b/codec2.spec
@@ -46,14 +46,16 @@ Example code for Codec 2
%build
-%cmake -DCMAKE_BUILD_TYPE=RelWithDebInfo \
- -DLPCNET=ON
+cmake -DCMAKE_BUILD_TYPE=RelWithDebInfo \
+ -DLPCNET=ON \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -B build
-%cmake_build
+cmake --build build
%install
-%cmake_install
+DESTDIR="%{buildroot}" cmake --install build
# Create and install pkgconfig file
mkdir -p %{buildroot}%{_libdir}/pkgconfig