summaryrefslogtreecommitdiff
path: root/python-bdspace.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-bdspace.spec')
-rw-r--r--python-bdspace.spec200
1 files changed, 200 insertions, 0 deletions
diff --git a/python-bdspace.spec b/python-bdspace.spec
new file mode 100644
index 0000000..ca2f9b2
--- /dev/null
+++ b/python-bdspace.spec
@@ -0,0 +1,200 @@
+%global _empty_manifest_terminate_build 0
+Name: python-BDSpace
+Version: 0.3.14
+Release: 1
+Summary: 3D space positioning and motion
+License: Apache Software License
+URL: https://github.com/bond-anton/BDSpace
+Source0: https://mirrors.aliyun.com/pypi/web/packages/6e/8b/eac642494280e90c17822d2a623a197df4cdd077ca5174f982380254d890/BDSpace-0.3.14.tar.gz
+
+
+%description
+# BDSpace
+
+![Build](https://github.com/bond-anton/BDSpace/workflows/Build/badge.svg)
+[![codecov](https://codecov.io/gh/bond-anton/BDSpace/branch/master/graph/badge.svg)](https://codecov.io/gh/bond-anton/BDSpace)
+
+**BDSpace** is a python package to simplify positioning, movement, and trajectory calculation for many
+different technical problems. It is mainly for multiple interacting bodies systems like coordinate stages
+and machining tools, robotic arms, manipulators, etc.
+
+**BDSpace** provides following basic features:
+
+|Feature |Staus |
+|--------------------------------------|------------------|
+|Cartesian coordinate systems |done |
+|Spherical coordinates |done |
+|Cylindrical coordinates |done |
+|Conversion between coordinate systems |done |
+|Multiple nested coordinate systems |done |
+|Parametric curves |done |
+|Trajectory builder (Pathfinder module)|endless work |
+|Planes and plane geometry |work in progress |
+|... |discussion is open|
+
+## Installation
+
+BDSpace depends on numpy and [BDQuaternions](https://github.com/bond-anton/BDQuaternions) packages only.
+It is compatible with Python 2 and Python 3.
+
+To install BDSpace type in a shell
+```shell
+pip install BDSpace
+```
+or in the root directory of BDQuaternions distribution run
+```shell
+python setup.py install
+```
+## Usage
+
+Please see the demo directory for the usage examples.
+
+## License
+
+BDSpace is free open source software licensed under Apache license version 2.0
+
+%package -n python3-BDSpace
+Summary: 3D space positioning and motion
+Provides: python-BDSpace
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+BuildRequires: python3-cffi
+BuildRequires: gcc
+BuildRequires: gdb
+%description -n python3-BDSpace
+# BDSpace
+
+![Build](https://github.com/bond-anton/BDSpace/workflows/Build/badge.svg)
+[![codecov](https://codecov.io/gh/bond-anton/BDSpace/branch/master/graph/badge.svg)](https://codecov.io/gh/bond-anton/BDSpace)
+
+**BDSpace** is a python package to simplify positioning, movement, and trajectory calculation for many
+different technical problems. It is mainly for multiple interacting bodies systems like coordinate stages
+and machining tools, robotic arms, manipulators, etc.
+
+**BDSpace** provides following basic features:
+
+|Feature |Staus |
+|--------------------------------------|------------------|
+|Cartesian coordinate systems |done |
+|Spherical coordinates |done |
+|Cylindrical coordinates |done |
+|Conversion between coordinate systems |done |
+|Multiple nested coordinate systems |done |
+|Parametric curves |done |
+|Trajectory builder (Pathfinder module)|endless work |
+|Planes and plane geometry |work in progress |
+|... |discussion is open|
+
+## Installation
+
+BDSpace depends on numpy and [BDQuaternions](https://github.com/bond-anton/BDQuaternions) packages only.
+It is compatible with Python 2 and Python 3.
+
+To install BDSpace type in a shell
+```shell
+pip install BDSpace
+```
+or in the root directory of BDQuaternions distribution run
+```shell
+python setup.py install
+```
+## Usage
+
+Please see the demo directory for the usage examples.
+
+## License
+
+BDSpace is free open source software licensed under Apache license version 2.0
+
+%package help
+Summary: Development documents and examples for BDSpace
+Provides: python3-BDSpace-doc
+%description help
+# BDSpace
+
+![Build](https://github.com/bond-anton/BDSpace/workflows/Build/badge.svg)
+[![codecov](https://codecov.io/gh/bond-anton/BDSpace/branch/master/graph/badge.svg)](https://codecov.io/gh/bond-anton/BDSpace)
+
+**BDSpace** is a python package to simplify positioning, movement, and trajectory calculation for many
+different technical problems. It is mainly for multiple interacting bodies systems like coordinate stages
+and machining tools, robotic arms, manipulators, etc.
+
+**BDSpace** provides following basic features:
+
+|Feature |Staus |
+|--------------------------------------|------------------|
+|Cartesian coordinate systems |done |
+|Spherical coordinates |done |
+|Cylindrical coordinates |done |
+|Conversion between coordinate systems |done |
+|Multiple nested coordinate systems |done |
+|Parametric curves |done |
+|Trajectory builder (Pathfinder module)|endless work |
+|Planes and plane geometry |work in progress |
+|... |discussion is open|
+
+## Installation
+
+BDSpace depends on numpy and [BDQuaternions](https://github.com/bond-anton/BDQuaternions) packages only.
+It is compatible with Python 2 and Python 3.
+
+To install BDSpace type in a shell
+```shell
+pip install BDSpace
+```
+or in the root directory of BDQuaternions distribution run
+```shell
+python setup.py install
+```
+## Usage
+
+Please see the demo directory for the usage examples.
+
+## License
+
+BDSpace is free open source software licensed under Apache license version 2.0
+
+%prep
+%autosetup -n BDSpace-0.3.14
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-BDSpace -f filelist.lst
+%dir %{python3_sitearch}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Tue Jun 20 2023 Python_Bot <Python_Bot@openeuler.org> - 0.3.14-1
+- Package Spec generated