summaryrefslogtreecommitdiff
path: root/python-geojsoncontour.spec
diff options
context:
space:
mode:
authorCoprDistGit <infra@openeuler.org>2023-05-10 08:10:32 +0000
committerCoprDistGit <infra@openeuler.org>2023-05-10 08:10:32 +0000
commit71bf78e8c5a56cb8eeed1040231309263de9ed11 (patch)
treefced0c912e46868e53a629f1a8c1ca4b1883c0be /python-geojsoncontour.spec
parentffb499928801675781ba16b973a4516bcd54a51a (diff)
automatic import of python-geojsoncontour
Diffstat (limited to 'python-geojsoncontour.spec')
-rw-r--r--python-geojsoncontour.spec331
1 files changed, 331 insertions, 0 deletions
diff --git a/python-geojsoncontour.spec b/python-geojsoncontour.spec
new file mode 100644
index 0000000..db6f0e1
--- /dev/null
+++ b/python-geojsoncontour.spec
@@ -0,0 +1,331 @@
+%global _empty_manifest_terminate_build 0
+Name: python-geojsoncontour
+Version: 0.4.0
+Release: 1
+Summary: Convert matplotlib contour plots to geojson
+License: MIT
+URL: http://github.com/bartromgens/geojsoncontour
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/32/79/916b4de820ba7aa7d09c4a189056521ee968996f68ab42fb46278f196855/geojsoncontour-0.4.0.tar.gz
+BuildArch: noarch
+
+Requires: python3-geojson
+Requires: python3-numpy
+Requires: python3-matplotlib
+Requires: python3-xarray
+
+%description
+# geojsoncontour
+[![Build Status](https://travis-ci.org/bartromgens/geojsoncontour.svg?branch=master)](https://travis-ci.org/bartromgens/geojsoncontour) [![PyPI version](https://badge.fury.io/py/geojsoncontour.svg)](https://badge.fury.io/py/geojsoncontour) [![Coverage Status](https://coveralls.io/repos/github/bartromgens/geojsoncontour/badge.svg?branch=master)](https://coveralls.io/github/bartromgens/geojsoncontour?branch=master)
+A Python 3 module to convert matplotlib contour plots to geojson. Supports both contour and contourf plots.
+
+Designed to show geographical [contour plots](http://matplotlib.org/examples/pylab_examples/contour_demo.html),
+created with [matplotlib/pyplot](https://github.com/matplotlib/matplotlib), as vector layer on interactive slippy maps like [OpenLayers](https://github.com/openlayers/ol3) and [Leaflet](https://github.com/Leaflet/Leaflet).
+
+Demo project that uses geojsoncontour: [climatemaps.romgens.com](http://climatemaps.romgens.com)
+
+![geojson contour demo usage](https://raw.githubusercontent.com/bartromgens/geojsoncontour/master/data/example_climatemaps.png)
+
+## Installation
+Install with pip,
+```
+pip install geojsoncontour
+```
+
+## Usage
+
+Use `contour_to_geojson` to create a geojson with contour lines from a `matplotlib.contour` plot (not filled).
+Use `contourf_to_geojson` to create a geojson with filled contours from a `matplotlib.contourf` plot.
+
+### Contour plot to geojson
+```python
+import numpy
+import matplotlib.pyplot as plt
+import geojsoncontour
+
+# Create contour data lon_range, lat_range, Z
+<your code here>
+
+# Create a contour plot plot from grid (lat, lon) data
+figure = plt.figure()
+ax = figure.add_subplot(111)
+contour = ax.contour(lon_range, lat_range, Z, cmap=plt.cm.jet)
+
+# Convert matplotlib contour to geojson
+geojson = geojsoncontour.contour_to_geojson(
+ contour=contour,
+ ndigits=3,
+ unit='m'
+)
+```
+For filled contour plots (`matplotlib.contourf`) use `contourf_to_geojson`.
+See [example_contour.py](examples/example_contour.py) and [example_contourf.py](examples/example_contourf.py) for simple but complete examples.
+
+### Show the geojson on a map
+An easy way to show the generated geojson on a map is the online geojson renderer [geojson.io](http://geojson.io) or [geojson.tools](http://geojson.tools).
+
+### Style properties
+Stroke color and width are set as geojson properties following https://github.com/mapbox/simplestyle-spec.
+
+### Create geojson tiles
+Try [geojson-vt](https://github.com/mapbox/geojson-vt) or [tippecanoe](https://github.com/mapbox/tippecanoe) if performance is an issue and you need to tile your geojson contours.
+
+
+## Development
+
+### Tests
+
+Run all tests,
+```
+python -m unittest discover
+```
+
+### Release
+
+Install setuptools, wheel and twine:
+```
+python -m pip install --upgrade setuptools wheel twine
+```
+
+Increase the version number in `setup.py`.
+
+Create dist:
+```
+python setup.py sdist bdist_wheel
+```
+
+Upload:
+```
+twine upload dist/*
+```
+
+
+
+
+%package -n python3-geojsoncontour
+Summary: Convert matplotlib contour plots to geojson
+Provides: python-geojsoncontour
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-geojsoncontour
+# geojsoncontour
+[![Build Status](https://travis-ci.org/bartromgens/geojsoncontour.svg?branch=master)](https://travis-ci.org/bartromgens/geojsoncontour) [![PyPI version](https://badge.fury.io/py/geojsoncontour.svg)](https://badge.fury.io/py/geojsoncontour) [![Coverage Status](https://coveralls.io/repos/github/bartromgens/geojsoncontour/badge.svg?branch=master)](https://coveralls.io/github/bartromgens/geojsoncontour?branch=master)
+A Python 3 module to convert matplotlib contour plots to geojson. Supports both contour and contourf plots.
+
+Designed to show geographical [contour plots](http://matplotlib.org/examples/pylab_examples/contour_demo.html),
+created with [matplotlib/pyplot](https://github.com/matplotlib/matplotlib), as vector layer on interactive slippy maps like [OpenLayers](https://github.com/openlayers/ol3) and [Leaflet](https://github.com/Leaflet/Leaflet).
+
+Demo project that uses geojsoncontour: [climatemaps.romgens.com](http://climatemaps.romgens.com)
+
+![geojson contour demo usage](https://raw.githubusercontent.com/bartromgens/geojsoncontour/master/data/example_climatemaps.png)
+
+## Installation
+Install with pip,
+```
+pip install geojsoncontour
+```
+
+## Usage
+
+Use `contour_to_geojson` to create a geojson with contour lines from a `matplotlib.contour` plot (not filled).
+Use `contourf_to_geojson` to create a geojson with filled contours from a `matplotlib.contourf` plot.
+
+### Contour plot to geojson
+```python
+import numpy
+import matplotlib.pyplot as plt
+import geojsoncontour
+
+# Create contour data lon_range, lat_range, Z
+<your code here>
+
+# Create a contour plot plot from grid (lat, lon) data
+figure = plt.figure()
+ax = figure.add_subplot(111)
+contour = ax.contour(lon_range, lat_range, Z, cmap=plt.cm.jet)
+
+# Convert matplotlib contour to geojson
+geojson = geojsoncontour.contour_to_geojson(
+ contour=contour,
+ ndigits=3,
+ unit='m'
+)
+```
+For filled contour plots (`matplotlib.contourf`) use `contourf_to_geojson`.
+See [example_contour.py](examples/example_contour.py) and [example_contourf.py](examples/example_contourf.py) for simple but complete examples.
+
+### Show the geojson on a map
+An easy way to show the generated geojson on a map is the online geojson renderer [geojson.io](http://geojson.io) or [geojson.tools](http://geojson.tools).
+
+### Style properties
+Stroke color and width are set as geojson properties following https://github.com/mapbox/simplestyle-spec.
+
+### Create geojson tiles
+Try [geojson-vt](https://github.com/mapbox/geojson-vt) or [tippecanoe](https://github.com/mapbox/tippecanoe) if performance is an issue and you need to tile your geojson contours.
+
+
+## Development
+
+### Tests
+
+Run all tests,
+```
+python -m unittest discover
+```
+
+### Release
+
+Install setuptools, wheel and twine:
+```
+python -m pip install --upgrade setuptools wheel twine
+```
+
+Increase the version number in `setup.py`.
+
+Create dist:
+```
+python setup.py sdist bdist_wheel
+```
+
+Upload:
+```
+twine upload dist/*
+```
+
+
+
+
+%package help
+Summary: Development documents and examples for geojsoncontour
+Provides: python3-geojsoncontour-doc
+%description help
+# geojsoncontour
+[![Build Status](https://travis-ci.org/bartromgens/geojsoncontour.svg?branch=master)](https://travis-ci.org/bartromgens/geojsoncontour) [![PyPI version](https://badge.fury.io/py/geojsoncontour.svg)](https://badge.fury.io/py/geojsoncontour) [![Coverage Status](https://coveralls.io/repos/github/bartromgens/geojsoncontour/badge.svg?branch=master)](https://coveralls.io/github/bartromgens/geojsoncontour?branch=master)
+A Python 3 module to convert matplotlib contour plots to geojson. Supports both contour and contourf plots.
+
+Designed to show geographical [contour plots](http://matplotlib.org/examples/pylab_examples/contour_demo.html),
+created with [matplotlib/pyplot](https://github.com/matplotlib/matplotlib), as vector layer on interactive slippy maps like [OpenLayers](https://github.com/openlayers/ol3) and [Leaflet](https://github.com/Leaflet/Leaflet).
+
+Demo project that uses geojsoncontour: [climatemaps.romgens.com](http://climatemaps.romgens.com)
+
+![geojson contour demo usage](https://raw.githubusercontent.com/bartromgens/geojsoncontour/master/data/example_climatemaps.png)
+
+## Installation
+Install with pip,
+```
+pip install geojsoncontour
+```
+
+## Usage
+
+Use `contour_to_geojson` to create a geojson with contour lines from a `matplotlib.contour` plot (not filled).
+Use `contourf_to_geojson` to create a geojson with filled contours from a `matplotlib.contourf` plot.
+
+### Contour plot to geojson
+```python
+import numpy
+import matplotlib.pyplot as plt
+import geojsoncontour
+
+# Create contour data lon_range, lat_range, Z
+<your code here>
+
+# Create a contour plot plot from grid (lat, lon) data
+figure = plt.figure()
+ax = figure.add_subplot(111)
+contour = ax.contour(lon_range, lat_range, Z, cmap=plt.cm.jet)
+
+# Convert matplotlib contour to geojson
+geojson = geojsoncontour.contour_to_geojson(
+ contour=contour,
+ ndigits=3,
+ unit='m'
+)
+```
+For filled contour plots (`matplotlib.contourf`) use `contourf_to_geojson`.
+See [example_contour.py](examples/example_contour.py) and [example_contourf.py](examples/example_contourf.py) for simple but complete examples.
+
+### Show the geojson on a map
+An easy way to show the generated geojson on a map is the online geojson renderer [geojson.io](http://geojson.io) or [geojson.tools](http://geojson.tools).
+
+### Style properties
+Stroke color and width are set as geojson properties following https://github.com/mapbox/simplestyle-spec.
+
+### Create geojson tiles
+Try [geojson-vt](https://github.com/mapbox/geojson-vt) or [tippecanoe](https://github.com/mapbox/tippecanoe) if performance is an issue and you need to tile your geojson contours.
+
+
+## Development
+
+### Tests
+
+Run all tests,
+```
+python -m unittest discover
+```
+
+### Release
+
+Install setuptools, wheel and twine:
+```
+python -m pip install --upgrade setuptools wheel twine
+```
+
+Increase the version number in `setup.py`.
+
+Create dist:
+```
+python setup.py sdist bdist_wheel
+```
+
+Upload:
+```
+twine upload dist/*
+```
+
+
+
+
+%prep
+%autosetup -n geojsoncontour-0.4.0
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-geojsoncontour -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Wed May 10 2023 Python_Bot <Python_Bot@openeuler.org> - 0.4.0-1
+- Package Spec generated