summaryrefslogtreecommitdiff
path: root/python-ml-insights.spec
diff options
context:
space:
mode:
authorCoprDistGit <infra@openeuler.org>2023-05-05 11:16:14 +0000
committerCoprDistGit <infra@openeuler.org>2023-05-05 11:16:14 +0000
commit0dceede095c0c391c3f34273da6a9da8a2dd16e8 (patch)
tree9b3d4aebde19a904802db72eb49d320e587b5ddb /python-ml-insights.spec
parentf7da5632450b1aff2022686e71e914ce67ba7900 (diff)
automatic import of python-ml-insightsopeneuler20.03
Diffstat (limited to 'python-ml-insights.spec')
-rw-r--r--python-ml-insights.spec144
1 files changed, 144 insertions, 0 deletions
diff --git a/python-ml-insights.spec b/python-ml-insights.spec
new file mode 100644
index 0000000..ed224e9
--- /dev/null
+++ b/python-ml-insights.spec
@@ -0,0 +1,144 @@
+%global _empty_manifest_terminate_build 0
+Name: python-ml-insights
+Version: 1.0.2
+Release: 1
+Summary: Package to calibrate and understand ML Models
+License: MIT license
+URL: http://ml-insights.readthedocs.io/en/latest/
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/21/a3/b43ed7c627ceabb7c30c583e3bd67a7d15be10722da2a1d8c0320c99ff82/ml_insights-1.0.2.tar.gz
+BuildArch: noarch
+
+Requires: python3-pandas
+Requires: python3-numpy
+Requires: python3-matplotlib
+Requires: python3-scikit-learn
+Requires: python3-scipy
+Requires: python3-splinecalib
+
+%description
+Welcome to ML-Insights!
+This package contains two core sets of functions:
+1) Calibration
+2) Interpreting Models
+For probability calibration, the main class is `SplineCalib`. Given a set of model outputs and the "true" classes, you can `fit` a SplineCalib object. That object can then be used to `calibrate` future model predictions post-hoc.
+ >>> model.fit(X_train, y_train)
+ >>> sc = mli.SplineCalib()
+ >>> sc.fit(X_valid, y_valid)
+ >>> uncalib_preds = model.predict_proba(X_test)
+ >>> calib_preds = sc.calibrate(uncalib_preds)
+ >>> cv_preds = mli.cv_predictions(model, X_train, y_train)
+ >>> model.fit(X_train, y_train)
+ >>> sc = mli.SplineCalib()
+ >>> sc.fit(cv_preds, y_train)
+ >>> uncalib_preds = model.predict_proba(X_test)
+ >>> calib_preds = sc.calibrate(uncalib_preds)
+For model interpretability, we provide the `ice_plot` and `histogram_pair` functions as well as other tools.
+ >>> rd = mli.get_range_dict(X_train)
+ >>> mli.ice_plot(model, X_test.sample(3), X_train.columns, rd)
+ >>> mli.histogram_pair(df.outcome, df.feature, bins=np.linspace(0,100,11))
+Please see the documentation and examples at the links below.
+- `Documentation <https://ml-insights.readthedocs.io>`_
+- `Notebook Examples and Usage <https://github.com/numeristical/introspective/tree/master/examples>`_
+
+%package -n python3-ml-insights
+Summary: Package to calibrate and understand ML Models
+Provides: python-ml-insights
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-ml-insights
+Welcome to ML-Insights!
+This package contains two core sets of functions:
+1) Calibration
+2) Interpreting Models
+For probability calibration, the main class is `SplineCalib`. Given a set of model outputs and the "true" classes, you can `fit` a SplineCalib object. That object can then be used to `calibrate` future model predictions post-hoc.
+ >>> model.fit(X_train, y_train)
+ >>> sc = mli.SplineCalib()
+ >>> sc.fit(X_valid, y_valid)
+ >>> uncalib_preds = model.predict_proba(X_test)
+ >>> calib_preds = sc.calibrate(uncalib_preds)
+ >>> cv_preds = mli.cv_predictions(model, X_train, y_train)
+ >>> model.fit(X_train, y_train)
+ >>> sc = mli.SplineCalib()
+ >>> sc.fit(cv_preds, y_train)
+ >>> uncalib_preds = model.predict_proba(X_test)
+ >>> calib_preds = sc.calibrate(uncalib_preds)
+For model interpretability, we provide the `ice_plot` and `histogram_pair` functions as well as other tools.
+ >>> rd = mli.get_range_dict(X_train)
+ >>> mli.ice_plot(model, X_test.sample(3), X_train.columns, rd)
+ >>> mli.histogram_pair(df.outcome, df.feature, bins=np.linspace(0,100,11))
+Please see the documentation and examples at the links below.
+- `Documentation <https://ml-insights.readthedocs.io>`_
+- `Notebook Examples and Usage <https://github.com/numeristical/introspective/tree/master/examples>`_
+
+%package help
+Summary: Development documents and examples for ml-insights
+Provides: python3-ml-insights-doc
+%description help
+Welcome to ML-Insights!
+This package contains two core sets of functions:
+1) Calibration
+2) Interpreting Models
+For probability calibration, the main class is `SplineCalib`. Given a set of model outputs and the "true" classes, you can `fit` a SplineCalib object. That object can then be used to `calibrate` future model predictions post-hoc.
+ >>> model.fit(X_train, y_train)
+ >>> sc = mli.SplineCalib()
+ >>> sc.fit(X_valid, y_valid)
+ >>> uncalib_preds = model.predict_proba(X_test)
+ >>> calib_preds = sc.calibrate(uncalib_preds)
+ >>> cv_preds = mli.cv_predictions(model, X_train, y_train)
+ >>> model.fit(X_train, y_train)
+ >>> sc = mli.SplineCalib()
+ >>> sc.fit(cv_preds, y_train)
+ >>> uncalib_preds = model.predict_proba(X_test)
+ >>> calib_preds = sc.calibrate(uncalib_preds)
+For model interpretability, we provide the `ice_plot` and `histogram_pair` functions as well as other tools.
+ >>> rd = mli.get_range_dict(X_train)
+ >>> mli.ice_plot(model, X_test.sample(3), X_train.columns, rd)
+ >>> mli.histogram_pair(df.outcome, df.feature, bins=np.linspace(0,100,11))
+Please see the documentation and examples at the links below.
+- `Documentation <https://ml-insights.readthedocs.io>`_
+- `Notebook Examples and Usage <https://github.com/numeristical/introspective/tree/master/examples>`_
+
+%prep
+%autosetup -n ml-insights-1.0.2
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-ml-insights -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Fri May 05 2023 Python_Bot <Python_Bot@openeuler.org> - 1.0.2-1
+- Package Spec generated