summaryrefslogtreecommitdiff
path: root/python-naive-bayes.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-naive-bayes.spec')
-rw-r--r--python-naive-bayes.spec219
1 files changed, 219 insertions, 0 deletions
diff --git a/python-naive-bayes.spec b/python-naive-bayes.spec
new file mode 100644
index 0000000..5dfdb26
--- /dev/null
+++ b/python-naive-bayes.spec
@@ -0,0 +1,219 @@
+%global _empty_manifest_terminate_build 0
+Name: python-naive-bayes
+Version: 0.1.1
+Release: 1
+Summary: Naive Bayes Text Classification
+License: MIT
+URL: https://github.com/itdxer/naive-bayes
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/ab/aa/75158e517a7678485e9a748b3117ce5edb750af643b2a916b061ee53ba4d/naive-bayes-0.1.1.tar.gz
+BuildArch: noarch
+
+
+%description
+# Naive Bayes Text Classifier
+
+Text classifier based on Naive Bayes.
+
+## Instalation
+
+```bash
+$ pip install naive-bayes
+```
+
+## Usage example
+
+```python
+from naivebayes import NaiveBayesTextClassifier
+
+classifier = NaiveBayesTextClassifier(
+ categories=categories_list,
+ stop_words=stopwords_list
+)
+classifier.train(train_docs, train_classes)
+predicted_classes = classifier.classify(test_docs)
+```
+
+`NaiveBayesTextClassifier` is a simple wrapper around `scikit-learn` class `CountVectorizer`. You can put all arguments which support this class. For more information please check `scikit-learn` official documentation.
+
+## More examples
+
+Check examples at `examples` folder. Before run them, install requirements in this folder.
+
+Clone repository from github
+
+```bash
+$ git clone git@github.com:itdxer/naive-bayes.git
+$ cd naive-bayes/examples
+$ pip install -r requirements.txt
+```
+
+And run some example
+
+### Usenet 20 newsgroup
+
+```bash
+$ python 20newsgroup
+```
+
+### Kaggle IMDB reviews competition
+
+```bash
+$ python imdb_reviews
+```
+
+%package -n python3-naive-bayes
+Summary: Naive Bayes Text Classification
+Provides: python-naive-bayes
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-naive-bayes
+# Naive Bayes Text Classifier
+
+Text classifier based on Naive Bayes.
+
+## Instalation
+
+```bash
+$ pip install naive-bayes
+```
+
+## Usage example
+
+```python
+from naivebayes import NaiveBayesTextClassifier
+
+classifier = NaiveBayesTextClassifier(
+ categories=categories_list,
+ stop_words=stopwords_list
+)
+classifier.train(train_docs, train_classes)
+predicted_classes = classifier.classify(test_docs)
+```
+
+`NaiveBayesTextClassifier` is a simple wrapper around `scikit-learn` class `CountVectorizer`. You can put all arguments which support this class. For more information please check `scikit-learn` official documentation.
+
+## More examples
+
+Check examples at `examples` folder. Before run them, install requirements in this folder.
+
+Clone repository from github
+
+```bash
+$ git clone git@github.com:itdxer/naive-bayes.git
+$ cd naive-bayes/examples
+$ pip install -r requirements.txt
+```
+
+And run some example
+
+### Usenet 20 newsgroup
+
+```bash
+$ python 20newsgroup
+```
+
+### Kaggle IMDB reviews competition
+
+```bash
+$ python imdb_reviews
+```
+
+%package help
+Summary: Development documents and examples for naive-bayes
+Provides: python3-naive-bayes-doc
+%description help
+# Naive Bayes Text Classifier
+
+Text classifier based on Naive Bayes.
+
+## Instalation
+
+```bash
+$ pip install naive-bayes
+```
+
+## Usage example
+
+```python
+from naivebayes import NaiveBayesTextClassifier
+
+classifier = NaiveBayesTextClassifier(
+ categories=categories_list,
+ stop_words=stopwords_list
+)
+classifier.train(train_docs, train_classes)
+predicted_classes = classifier.classify(test_docs)
+```
+
+`NaiveBayesTextClassifier` is a simple wrapper around `scikit-learn` class `CountVectorizer`. You can put all arguments which support this class. For more information please check `scikit-learn` official documentation.
+
+## More examples
+
+Check examples at `examples` folder. Before run them, install requirements in this folder.
+
+Clone repository from github
+
+```bash
+$ git clone git@github.com:itdxer/naive-bayes.git
+$ cd naive-bayes/examples
+$ pip install -r requirements.txt
+```
+
+And run some example
+
+### Usenet 20 newsgroup
+
+```bash
+$ python 20newsgroup
+```
+
+### Kaggle IMDB reviews competition
+
+```bash
+$ python imdb_reviews
+```
+
+%prep
+%autosetup -n naive-bayes-0.1.1
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-naive-bayes -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Fri May 05 2023 Python_Bot <Python_Bot@openeuler.org> - 0.1.1-1
+- Package Spec generated